summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:41:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:41:27 +0000
commit7bde54f4402d43a2d8aafba7d885c9a934264fc0 (patch)
treeb97b0c27f020cb706f1c454132bcd4dd5e41db71 /x11-libs/xpyb
parentFix configure warning for 1.14.25. Patch to conditionally install English sta... (diff)
downloadgentoo-2-7bde54f4402d43a2d8aafba7d885c9a934264fc0.tar.gz
gentoo-2-7bde54f4402d43a2d8aafba7d885c9a934264fc0.tar.bz2
gentoo-2-7bde54f4402d43a2d8aafba7d885c9a934264fc0.zip
Move use_ functions out of global scope.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/xpyb')
-rw-r--r--x11-libs/xpyb/ChangeLog6
-rw-r--r--x11-libs/xpyb/xpyb-0.9.ebuild9
-rw-r--r--x11-libs/xpyb/xpyb-1.0.ebuild7
3 files changed, 16 insertions, 6 deletions
diff --git a/x11-libs/xpyb/ChangeLog b/x11-libs/xpyb/ChangeLog
index d4f8bf26d178..b74a69c6a763 100644
--- a/x11-libs/xpyb/ChangeLog
+++ b/x11-libs/xpyb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/xpyb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/ChangeLog,v 1.4 2009/01/13 02:41:56 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/ChangeLog,v 1.5 2009/05/04 15:41:27 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> xpyb-0.9.ebuild,
+ xpyb-1.0.ebuild:
+ Move use_ functions out of global scope.
*xpyb-1.0 (13 Jan 2009)
diff --git a/x11-libs/xpyb/xpyb-0.9.ebuild b/x11-libs/xpyb/xpyb-0.9.ebuild
index eaa93681ba01..6f4399d1bce0 100644
--- a/x11-libs/xpyb/xpyb-0.9.ebuild
+++ b/x11-libs/xpyb/xpyb-0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-0.9.ebuild,v 1.3 2008/07/30 22:34:30 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-0.9.ebuild,v 1.4 2009/05/04 15:41:27 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -17,5 +17,8 @@ RDEPEND=">=x11-libs/libxcb-1.1
>=dev-lang/python-2.5"
DEPEND="${RDEPEND}
>=x11-proto/xcb-proto-1.2"
-CONFIGURE_OPTIONS="$(use_enable selinux xselinux)"
DOCS="NEWS README"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable selinux xselinux)"
+}
diff --git a/x11-libs/xpyb/xpyb-1.0.ebuild b/x11-libs/xpyb/xpyb-1.0.ebuild
index 192f548238af..821aa6533fd0 100644
--- a/x11-libs/xpyb/xpyb-1.0.ebuild
+++ b/x11-libs/xpyb/xpyb-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.0.ebuild,v 1.1 2009/01/13 02:41:56 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.0.ebuild,v 1.2 2009/05/04 15:41:27 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -17,5 +17,8 @@ RDEPEND=">=x11-libs/libxcb-1.1
>=dev-lang/python-2.5"
DEPEND="${RDEPEND}
>=x11-proto/xcb-proto-1.2"
-CONFIGURE_OPTIONS="$(use_enable selinux xselinux)"
DOCS="NEWS README"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable selinux xselinux)"
+}