summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-03-29 22:52:34 +0000
committerMatt Turner <mattst88@gentoo.org>2012-03-29 22:52:34 +0000
commit0f948cdc78b55893d938564b2edc6c92974c75bd (patch)
treec7a4fd057803ee8455bd40d647d3407f5ec2f46c /x11-libs
parentEAPI=4; add :4 slot to dependencies and sort them. (diff)
downloadgentoo-2-0f948cdc78b55893d938564b2edc6c92974c75bd.tar.gz
gentoo-2-0f948cdc78b55893d938564b2edc6c92974c75bd.tar.bz2
gentoo-2-0f948cdc78b55893d938564b2edc6c92974c75bd.zip
Version bump. Drop 1.6.1-r1 and its patch.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXaw3d/ChangeLog8
-rw-r--r--x11-libs/libXaw3d/files/libXaw3d-1.6.1-use_after_free.patch39
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.2.ebuild (renamed from x11-libs/libXaw3d/libXaw3d-1.6.1-r1.ebuild)6
3 files changed, 9 insertions, 44 deletions
diff --git a/x11-libs/libXaw3d/ChangeLog b/x11-libs/libXaw3d/ChangeLog
index 48f372a7e679..4343d5f5d753 100644
--- a/x11-libs/libXaw3d/ChangeLog
+++ b/x11-libs/libXaw3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXaw3d
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw3d/ChangeLog,v 1.9 2012/03/05 09:45:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw3d/ChangeLog,v 1.10 2012/03/29 22:52:34 mattst88 Exp $
+
+*libXaw3d-1.6.2 (29 Mar 2012)
+
+ 29 Mar 2012; Matt Turner <mattst88@gentoo.org> -libXaw3d-1.6.1-r1.ebuild,
+ -files/libXaw3d-1.6.1-use_after_free.patch, +libXaw3d-1.6.2.ebuild:
+ Version bump. Drop 1.6.1-r1 and its patch.
05 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> -libXaw3d-1.6-r1.ebuild,
-libXaw3d-1.6.1.ebuild:
diff --git a/x11-libs/libXaw3d/files/libXaw3d-1.6.1-use_after_free.patch b/x11-libs/libXaw3d/files/libXaw3d-1.6.1-use_after_free.patch
deleted file mode 100644
index c419462299c0..000000000000
--- a/x11-libs/libXaw3d/files/libXaw3d-1.6.1-use_after_free.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From f435c05c64bc20557d901170b76f6bce8506ed48 Mon Sep 17 00:00:00 2001
-From: Matt Turner <mattst88@gmail.com>
-Date: Thu, 1 Mar 2012 16:48:23 -0500
-Subject: [PATCH libXaw3d] Fix use-after-free in DestroyAllIM
-
-Fixes segmentation fault when closing gv.
-
-Found at http://gitorious.org/xaw3d/xaw3d/commit/23b3ca50395f180cba4a923eb8827dcc961629da
-
-Fixes: https://bugs.gentoo.org/show_bug.cgi?id=406487
-Signed-off-by: Matt Turner <mattst88@gmail.com>
----
-Original author of this patch is unknown. If you know, let me know and
-I'll fix the attribution.
-
- src/XawIm.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/XawIm.c b/src/XawIm.c
-index 82a94b1..00562b5 100644
---- a/src/XawIm.c
-+++ b/src/XawIm.c
-@@ -320,12 +320,12 @@ DestroyAllIM(XawVendorShellExtPart *ve)
- /*
- * Close Input Method
- */
-- CloseIM(ve);
- if (!XFindContext(XDisplayOfIM(ve->im.xim), (Window)ve->im.xim, errContext,
- (XPointer*)&contextErrData)) {
- if (contextErrData) XtFree((char *)contextErrData);
- }
- XDeleteContext(XDisplayOfIM(ve->im.xim), (Window)ve->im.xim, errContext);
-+ CloseIM(ve);
- ve->im.xim = NULL;
-
- /*
---
-1.7.3.4
-
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.1-r1.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.2.ebuild
index a91aa79bff25..66f0194dfe9d 100644
--- a/x11-libs/libXaw3d/libXaw3d-1.6.1-r1.ebuild
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw3d/libXaw3d-1.6.1-r1.ebuild,v 1.1 2012/03/05 09:42:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw3d/libXaw3d-1.6.2.ebuild,v 1.1 2012/03/29 22:52:34 mattst88 Exp $
EAPI=4
inherit xorg-2
@@ -21,11 +21,9 @@ DEPEND="${RDEPEND}
x11-proto/xproto"
pkg_setup() {
- PATCHES=( "${FILESDIR}"/${P}-use_after_free.patch )
-
XORG_CONFIGURE_OPTIONS=(
$(use_enable unicode internationalization)
- )
+ )
xorg-2_pkg_setup
}