summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:47:56 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:47:56 +0000
commit2966fd76cf068b1b20a0e8adbc6a7c3ac8e0f6e3 (patch)
tree35d770d4d049fcf6903ac6da9480b44fe2e16b63 /x11-libs
parentVersion bump to Qt-4.4.0. (diff)
downloadgentoo-2-2966fd76cf068b1b20a0e8adbc6a7c3ac8e0f6e3.tar.gz
gentoo-2-2966fd76cf068b1b20a0e8adbc6a7c3ac8e0f6e3.tar.bz2
gentoo-2-2966fd76cf068b1b20a0e8adbc6a7c3ac8e0f6e3.zip
Version bump to Qt-4.4.0.
(Portage version: 2.1.5)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-script/ChangeLog7
-rw-r--r--x11-libs/qt-script/qt-script-4.4.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index b6f045ac170e..2b75cad65643 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.4 2008/04/10 13:42:44 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.5 2008/05/15 12:47:56 ingmar Exp $
+
+*qt-script-4.4.0 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +qt-script-4.4.0.ebuild:
+ Version bump to Qt-4.4.0.
10 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-qt-script-4.4.0_beta1.ebuild, +qt-script-4.4.0_rc1.ebuild:
diff --git a/x11-libs/qt-script/qt-script-4.4.0.ebuild b/x11-libs/qt-script/qt-script-4.4.0.ebuild
new file mode 100644
index 000000000000..9c1a228d45d4
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.4.0.ebuild,v 1.1 2008/05/15 12:47:56 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/global/
+src/corelib/kernel/
+src/corelib/plugin/"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+
+ qt4-build_src_compile
+}