summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-05-02 20:46:39 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-05-02 20:46:39 +0000
commit2a4ba2daafe8a63ea2792bfc9e8212dca5769c63 (patch)
tree788f05682f2be810cc902aa3bbf55a61094c6921 /x11-libs
parentamd64 stable wrt #317125 (diff)
downloadgentoo-2-2a4ba2daafe8a63ea2792bfc9e8212dca5769c63.tar.gz
gentoo-2-2a4ba2daafe8a63ea2792bfc9e8212dca5769c63.tar.bz2
gentoo-2-2a4ba2daafe8a63ea2792bfc9e8212dca5769c63.zip
Version bump to 0.1.11 , fixing RDEPEND versions, keywording ~x86
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm/ChangeLog7
-rw-r--r--x11-libs/libfm/libfm-0.1.11.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index 65429f5b7868..d27e5fca2c7a 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.5 2010/03/18 17:15:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.6 2010/05/02 20:46:39 vostorga Exp $
+
+*libfm-0.1.11 (02 May 2010)
+
+ 02 May 2010; Víctor Ostorga <vostorga@gentoo.org> +libfm-0.1.11.ebuild:
+ Version bump to 0.1.11 , fixing RDEPEND versions, keywording ~x86
*libfm-0.1.9 (18 Mar 2010)
diff --git a/x11-libs/libfm/libfm-0.1.11.ebuild b/x11-libs/libfm/libfm-0.1.11.ebuild
new file mode 100644
index 000000000000..2b246a9c520d
--- /dev/null
+++ b/x11-libs/libfm/libfm-0.1.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-0.1.11.ebuild,v 1.1 2010/05/02 20:46:39 vostorga Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcmanfm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug demo"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ >=lxde-base/menu-cache-0.3.2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ strip-linguas -i "${S}/po"
+ econf --sysconfdir=/etc $(use_enable debug) $(use_enable demo)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS TODO || die
+}