summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-05 15:19:56 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-05 15:19:56 +0000
commit30ab4f81bd044710efa4cc0ad66b148ce79a5bea (patch)
treecbdfe0d68ead167c8fa8248800804205767feb0b /x11-libs
parentBump for latest release, temporary mask (diff)
downloadgentoo-2-30ab4f81bd044710efa4cc0ad66b148ce79a5bea.tar.gz
gentoo-2-30ab4f81bd044710efa4cc0ad66b148ce79a5bea.tar.bz2
gentoo-2-30ab4f81bd044710efa4cc0ad66b148ce79a5bea.zip
Removing Qt-4.8.0
(Portage version: 2.2.0_alpha99/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-assistant/ChangeLog5
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild125
2 files changed, 4 insertions, 126 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 0f7a1571fcda..9f4cfe26c12e 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.126 2012/03/30 13:55:10 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.127 2012/04/05 15:19:56 johu Exp $
+
+ 05 Apr 2012; Johannes Huber <johu@gentoo.org> -qt-assistant-4.8.0-r1.ebuild:
+ Drop Qt-4.8.0
*qt-assistant-4.8.1-r1 (30 Mar 2012)
diff --git a/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild
deleted file mode 100644
index 35df3844613b..000000000000
--- a/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.8.0-r1.ebuild,v 1.1 2012/03/19 16:31:42 pesa Exp $
-
-EAPI="3"
-
-inherit qt4-build
-
-DESCRIPTION="The Help module and Assistant application for the Qt toolkit"
-SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
-SLOT="4"
-
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-IUSE="compat doc +glib qt3support trace webkit"
-
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,c++0x=,qpa=,debug=,glib=,qt3support=,trace?]
- ~x11-libs/qt-sql-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=,sqlite]
- webkit? ( ~x11-libs/qt-webkit-${PV}[aqua=,c++0x=,qpa=,debug=] )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- # bug 395067
- "${FILESDIR}/${P}-install-fix.patch"
-)
-
-pkg_setup() {
- # Pixeltool isn't really assistant related, but it relies on
- # the assistant libraries.
- QT4_TARGET_DIRECTORIES="
- tools/assistant
- tools/pixeltool
- tools/qdoc3"
- QT4_EXTRACT_DIRECTORIES="
- tools
- demos
- examples
- src
- include
- doc"
-
- use trace && QT4_TARGET_DIRECTORIES+=" tools/qttracereplay"
-
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- ${QT4_EXTRACT_DIRECTORIES}"
-
- qt4-build_pkg_setup
-}
-
-src_unpack() {
- qt4-build_src_unpack
- # compat version
- # http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
- if use compat; then
- unpack "${PN}"-qassistantclient-library-compat-src-4.6.3.tar.gz
- mv "${WORKDIR}"/"${PN}"-qassistantclient-library-compat-version-4.6.3 \
- "${S}"/tools/assistant/compat ||
- die "moving compat to the right place failed"
- tar xzf "${FILESDIR}"/"${PN}"-4.7-include.tar.gz -C "${S}"/include/ ||
- die "unpacking the include files failed"
- fi
-}
-
-src_prepare() {
- qt4-build_src_prepare
-
- use compat && epatch "${FILESDIR}"/${PN}-4.7-fix-compat.patch
-
- # bug 401173
- use webkit || epatch "${FILESDIR}"/disable-webkit.patch
-
- # bug 348034
- sed -i -e '/^sub-qdoc3\.depends/d' doc/doc.pri || die
-}
-
-src_configure() {
- myconf+="
- -no-xkb -no-fontconfig -no-xrandr
- -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-multimedia -no-svg
- $(qt_use qt3support) $(qt_use webkit)"
- use glib || myconf+=" -no-glib"
-
- qt4-build_src_configure
-}
-
-src_compile() {
- # help libQtHelp find freshly built libQtCLucene (bug #289811)
- export LD_LIBRARY_PATH="${S}/lib:${QTLIBDIR}"
- export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
-
- qt4-build_src_compile
-
- cd "${S}"
- # ugly hack to build docs
- qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
- emake qch_docs || die "emake qch_docs failed"
-
- if use doc; then
- emake docs || die "emake docs failed"
- fi
-}
-
-src_install() {
- qt4-build_src_install
-
- cd "${S}"
- emake INSTALL_ROOT="${D}" install_qchdocs || die "failed to install qch docs"
-
- if use doc; then
- emake INSTALL_ROOT="${D}" install_htmldocs || die "failed to install html docs"
- fi
-
- dobin "${S}"/bin/qdoc3 || die
-
- doicon tools/assistant/tools/assistant/images/assistant.png || die
- make_desktop_entry assistant Assistant assistant 'Qt;Development'
-
- if use compat; then
- insinto /usr/share/qt4/mkspecs/features
- doins tools/assistant/compat/features/assistant.prf || die
- fi
-}