summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-29 05:07:16 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-29 05:07:16 +0000
commit4b75099795d31e668d4aac4d37b8a39d3a8a8b43 (patch)
treee2b8ad1b982218094c5818b2bcc01fe7f5fc69d5 /x11-libs
parentFix p.mask date for emul-linux-x86. (diff)
downloadgentoo-2-4b75099795d31e668d4aac4d37b8a39d3a8a8b43.tar.gz
gentoo-2-4b75099795d31e668d4aac4d37b8a39d3a8a8b43.tar.bz2
gentoo-2-4b75099795d31e668d4aac4d37b8a39d3a8a8b43.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/amd-adl-sdk/ChangeLog5
-rw-r--r--x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild48
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/amd-adl-sdk/ChangeLog b/x11-libs/amd-adl-sdk/ChangeLog
index 0eef5c9f0e40..691bae11479a 100644
--- a/x11-libs/amd-adl-sdk/ChangeLog
+++ b/x11-libs/amd-adl-sdk/ChangeLog
@@ -1,4 +1,9 @@
+*amd-adl-sdk-8.0 (29 Mar 2015)
+
+ 29 Mar 2015; Manuel Rüger <mrueg@gentoo.org> +amd-adl-sdk-8.0.ebuild:
+ Version bump.
+
*amd-adl-sdk-7.0 (21 Dec 2014)
21 Dec 2014; Manuel Rüger <mrueg@gentoo.org> +amd-adl-sdk-7.0.ebuild:
diff --git a/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild b/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild
new file mode 100644
index 000000000000..d4d96e8c2ed4
--- /dev/null
+++ b/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/amd-adl-sdk/amd-adl-sdk-8.0.ebuild,v 1.1 2015/03/29 05:07:16 mrueg Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="API to access display driver functionality for ATI graphics cards"
+HOMEPAGE="http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/"
+SRC_URI="ADL_SDK${PV/.*/}.zip"
+
+LICENSE="AMD-ADL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="x11-drivers/ati-drivers"
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please visit the download page [1], rename ADL_SDK.zip to ${A} and save it in ${DISTDIR}"
+ einfo "[1] http://developer.amd.com/tools-and-sdks/graphics-development/display-library-adl-sdk/"
+}
+
+src_prepare() {
+ sed -i -e '/include/a \#include <wchar.h> \
+#include <stdbool.h>' include/adl_structures.h || die
+}
+
+src_compile() {
+ pushd adlutil
+ $(tc-getCC) main.c ${CFLAGS} -I ../include/ -DLINUX ${LDFLAGS} -o adlutil -ldl || die
+ popd
+}
+
+src_install() {
+ use doc && dodoc -r "Public-Documents"/* "adlutil/ADLUTIL User Guide.doc"
+ use examples && dodoc -r "Sample" "Sample-Managed"
+
+ dobin adlutil/adlutil
+ insinto "/usr/include/ADL"
+ doins include/*
+}