summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-07 19:17:21 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-07 19:17:21 +0000
commit61de44227de29600290f550ef1ed63f9605f8127 (patch)
tree7bed0e6887fe5a8c2de84dc40dd9085a53d27064 /x11-libs
parentStable for x86, wrt bug #502876 (diff)
downloadgentoo-2-61de44227de29600290f550ef1ed63f9605f8127.tar.gz
gentoo-2-61de44227de29600290f550ef1ed63f9605f8127.tar.bz2
gentoo-2-61de44227de29600290f550ef1ed63f9605f8127.zip
Enable multilib support, bug #512136.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtkglext/ChangeLog7
-rw-r--r--x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/x11-libs/gtkglext/ChangeLog b/x11-libs/gtkglext/ChangeLog
index 3fe8349dd1ea..69e4ad049cf7 100644
--- a/x11-libs/gtkglext/ChangeLog
+++ b/x11-libs/gtkglext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtkglext
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglext/ChangeLog,v 1.83 2014/04/27 09:28:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglext/ChangeLog,v 1.84 2014/06/07 19:17:21 mgorny Exp $
+
+*gtkglext-1.2.0-r2 (07 Jun 2014)
+
+ 07 Jun 2014; Michał Górny <mgorny@gentoo.org> +gtkglext-1.2.0-r2.ebuild:
+ Enable multilib support, bug #512136.
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -gtkglext-1.2.0.ebuild:
drop old
diff --git a/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild b/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..28472d3232f7
--- /dev/null
+++ b/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkglext/gtkglext-1.2.0-r2.ebuild,v 1.1 2014/06/07 19:17:21 mgorny Exp $
+
+EAPI="5"
+
+GNOME2_LA_PUNT="yes"
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GL extensions for Gtk+ 2.0"
+HOMEPAGE="http://gtkglext.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1[X,${MULTILIB_USEDEP}]
+ || (
+ x11-libs/pangox-compat[${MULTILIB_USEDEP}]
+ <x11-libs/pango-1.31[X,${MULTILIB_USEDEP}]
+ )
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ virtual/opengl[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove development knobs, bug #308973
+ sed -i 's:-D\(G.*DISABLE_DEPRECATED\):-D__\1__:g' \
+ examples/Makefile.am examples/Makefile.in \
+ gdk/Makefile.am gdk/Makefile.in \
+ gdk/win32/Makefile.am gdk/win32/Makefile.in \
+ gdk/x11/Makefile.am gdk/x11/Makefile.in \
+ gtk/Makefile.am gtk/Makefile.in \
+ || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS="AUTHORS ChangeLog* NEWS README TODO"
+ einstalldocs
+}