summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-14 14:40:05 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-14 14:40:05 +0000
commitb92798ca6d8b7a3f9236d73ce09fe4abbef38495 (patch)
tree038a8fe6283a717efaf89cf2c5b7a8be225065a6 /x11-libs
parentsci-chemistry/relax: Add missing dep on dev-python/wxpython (diff)
downloadgentoo-2-b92798ca6d8b7a3f9236d73ce09fe4abbef38495.tar.gz
gentoo-2-b92798ca6d8b7a3f9236d73ce09fe4abbef38495.tar.bz2
gentoo-2-b92798ca6d8b7a3f9236d73ce09fe4abbef38495.zip
Version bump. bug #465062
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libvdpau/ChangeLog7
-rw-r--r--x11-libs/libvdpau/libvdpau-0.6.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-libs/libvdpau/ChangeLog b/x11-libs/libvdpau/ChangeLog
index 5295840c6eb3..9b12cc328c46 100644
--- a/x11-libs/libvdpau/ChangeLog
+++ b/x11-libs/libvdpau/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libvdpau
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.27 2013/02/26 16:37:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/ChangeLog,v 1.28 2013/05/14 14:40:05 cardoe Exp $
+
+*libvdpau-0.6 (14 May 2013)
+
+ 14 May 2013; Doug Goldstein <cardoe@gentoo.org> +libvdpau-0.6.ebuild:
+ Version bump. bug #465062
*libvdpau-0.5-r1 (26 Feb 2013)
diff --git a/x11-libs/libvdpau/libvdpau-0.6.ebuild b/x11-libs/libvdpau/libvdpau-0.6.ebuild
new file mode 100644
index 000000000000..368452999a5f
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libvdpau/libvdpau-0.6.ebuild,v 1.1 2013/05/14 14:40:05 cardoe Exp $
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="http://people.freedesktop.org/~aplattner/vdpau/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND="x11-libs/libX11[${MULTILIB_USEDEP}]
+ dri? ( x11-libs/libXext[${MULTILIB_USEDEP}] )
+ !=x11-drivers/nvidia-drivers-180*
+ !=x11-drivers/nvidia-drivers-185*
+ !=x11-drivers/nvidia-drivers-190*
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-xlibs-20130224 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( >=x11-proto/dri2proto-2.2 )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable doc documentation)
+ $(use dri || echo --disable-dri2)
+ )
+
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ prune_libtool_files --modules
+}