summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-17 13:22:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-17 13:22:29 +0000
commitb9f9885083e2d19a4e3db37bc78a3b9f5f82fd48 (patch)
treedf2822a67cf7902de9faadace6707459d9408478 /x11-libs
parentremoved enable-double config option (diff)
downloadgentoo-2-b9f9885083e2d19a4e3db37bc78a3b9f5f82fd48.tar.gz
gentoo-2-b9f9885083e2d19a4e3db37bc78a3b9f5f82fd48.tar.bz2
gentoo-2-b9f9885083e2d19a4e3db37bc78a3b9f5f82fd48.zip
version bump
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.52
-rw-r--r--x11-libs/gtk+/gtk+-2.0.5.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 1d0c6d8e13e2..b9b3335c1c27 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.16 2002/06/09 02:19:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.17 2002/06/17 13:22:29 seemant Exp $
+
+*gtk+-2.0.5 (17 Jun 2002)
+
+ 17 Jun 2002; Seemant Kulleen <seemant@gentoo.org> gtk+-2.0.5.ebuild
+ files/digest-2.0.5 :
+
+ Version bump for both regular GTK+2 and GTK+DirectFB
*gtk+-2.0.3-r1 (8 Jun 2002)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.5 b/x11-libs/gtk+/files/digest-gtk+-2.0.5
new file mode 100644
index 000000000000..0cc3d9034f1a
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.5
@@ -0,0 +1,2 @@
+MD5 dfa52595e76fd389c4d42c60412317e8 gtk+-2.0.5.tar.bz2 6017061
+MD5 d30c8ab8c1418351ef545950615ef1e6 gtk+-directfb-2.0.5.tar.gz 8582484
diff --git a/x11-libs/gtk+/gtk+-2.0.5.ebuild b/x11-libs/gtk+/gtk+-2.0.5.ebuild
new file mode 100644
index 000000000000..adf9000aad55
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.5.ebuild,v 1.1 2002/06/17 13:22:29 seemant Exp $
+
+inherit libtool
+
+SLOT="2"
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+use directfb && MY_P=gtk+-directfb-${PV} || MY_P=${P}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Gimp ToolKit + "
+ORIG="ftp://ftp.gtk.org/pub/gtk/v2.0/${MY_P}.tar.bz2"
+DFB="http://directfb.org/download/GTK+-DirectFB/${MY_P}.tar.gz"
+use directfb && SRC_URI=${DFB} || SRC_URI=${ORIG}
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.4
+ >=dev-libs/atk-1.0.2
+ >=x11-libs/pango-1.0.3
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ directfb? ( dev-libs/DirectFB )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-gdktarget=x11 \
+ ${myconf} \
+ --enable-debug || die
+# enable debug since glib fails if we disable it
+
+# gtk+ isn't multithread friendly due to some obscure code generation bug
+# make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+