summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-06 12:03:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-06 12:03:37 +0000
commit07833ed8961e422106a48f658551ef36932bcd0e (patch)
treec65587b6e2e54226e276e5416bafcedaee7ce4f2 /x11-misc/3ddesktop
parentFix .desktop file. (diff)
downloadgentoo-2-07833ed8961e422106a48f658551ef36932bcd0e.tar.gz
gentoo-2-07833ed8961e422106a48f658551ef36932bcd0e.tar.bz2
gentoo-2-07833ed8961e422106a48f658551ef36932bcd0e.zip
Move OpenGL calls after OpenGL initialization wrt #123762 by Yarda.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/3ddesktop')
-rw-r--r--x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild57
-rw-r--r--x11-misc/3ddesktop/ChangeLog10
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch23
3 files changed, 88 insertions, 2 deletions
diff --git a/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild b/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
new file mode 100644
index 000000000000..22a91d2accab
--- /dev/null
+++ b/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild,v 1.1 2010/06/06 12:03:37 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="OpenGL virtual desktop switching"
+HOMEPAGE="http://desk3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/desk3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ media-libs/imlib2
+ virtual/glut
+ media-libs/freetype"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-missing-include.patch \
+ "${FILESDIR}"/${P}-gl_init.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS TODO ChangeLog README README.windowmanagers
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This ebuild installed a configuration file called /etc/3ddesktop.conf"
+ einfo "The default configuration makes a screenshot of the virtual desktops"
+ einfo "every X seconds. This is non-optimal behavior."
+ einfo
+ einfo "To enable a more intelligent way of updating the virtual desktops,"
+ einfo "execute the following:"
+ einfo
+ einfo " echo \"AutoAcquire 0\" >> /etc/3ddesktop.conf"
+ einfo
+ einfo "This will cause 3ddesktop to update the virtual desktop snapshots"
+ einfo "only when a 3d desktop switch is required."
+ einfo
+}
diff --git a/x11-misc/3ddesktop/ChangeLog b/x11-misc/3ddesktop/ChangeLog
index ea5037915b51..b97bd9074673 100644
--- a/x11-misc/3ddesktop/ChangeLog
+++ b/x11-misc/3ddesktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/3ddesktop
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/ChangeLog,v 1.39 2008/12/17 18:48:58 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/ChangeLog,v 1.40 2010/06/06 12:03:37 ssuominen Exp $
+
+*3ddesktop-0.2.9-r1 (06 Jun 2010)
+
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +3ddesktop-0.2.9-r1.ebuild, +files/3ddesktop-0.2.9-gl_init.patch:
+ Move OpenGL calls after OpenGL initialization wrt #123762 by Yarda.
17 Dec 2008; Christoph Mende <angelos@gentoo.org>
+files/3ddesktop-0.2.9-asneeded.patch,
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch
new file mode 100644
index 000000000000..523e8c88f11f
--- /dev/null
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gl_init.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/123762
+
+--- 3ddeskd.cpp
++++ 3ddeskd.cpp
+@@ -2411,15 +2411,15 @@
+
+ // initialize opengl
+
+- // our own init function.
+- gl_init();
+-
+ GLWin.open_display();
+
+
+ GLWin.create_GL_window("Enhanced 3-dimensional workspace visualization magic machine",
+ cfg->options->do_fullscreen);
+
++ // our own init function.
++ gl_init();
++
+ cfg->texture_size = GLWin.get_best_texture_size(cfg->texture_size);
+
+ // Loads up the correct perspective matrix