summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-08-29 15:17:38 +0000
committerBen Lutgens <lamer@gentoo.org>2001-08-29 15:17:38 +0000
commit4e277b53b8831899939c9e64740550d86b49ed46 (patch)
tree933f575dfe421ebe51ae815be0f78c709adf0678 /x11-misc/bbkeys
parentMove into x11-misc (diff)
downloadgentoo-2-4e277b53b8831899939c9e64740550d86b49ed46.tar.gz
gentoo-2-4e277b53b8831899939c9e64740550d86b49ed46.tar.bz2
gentoo-2-4e277b53b8831899939c9e64740550d86b49ed46.zip
heh
Diffstat (limited to 'x11-misc/bbkeys')
-rw-r--r--x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild40
-rw-r--r--x11-misc/bbkeys/bbkeys-0.8.2.ebuild28
-rw-r--r--x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r11
-rw-r--r--x11-misc/bbkeys/files/digest-bbkeys-0.8.21
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild b/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..039f7af139a5
--- /dev/null
+++ b/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild,v 1.1 2001/08/29 15:17:38 lamer Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="bbkeys"
+SRC_URI="http://movingparts.thelinuxcommunity.org/bbkeys/${A}"
+HOMEPAGE="http://movingparts.thelinuxcommunity.org"
+
+DEPEND=">=x11-wm/blackbox-0.61 qt? ( >=x11-libs/qt-x11-2.3.0 )"
+
+src_compile() {
+
+ if [ "`use qt`" ] ; then
+ cd ${S}/bbkeysconf-1.3
+ local qtdir=${QTDIR}
+ try make MOC=${qtdir}/bin/moc CXXFLAGS="-I${qtdir}/include" LIBS="-L${qtdir}/lib -L/usr/X11R6/lib -lqt -lX11"
+ fi
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ if [ "`use qt`" ] ; then
+ cd ${S}/bbkeysconf-1.3
+ into /usr/X11R6
+ dobin bbkeysconf
+ fi
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbkeys \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/x11-misc/bbkeys/bbkeys-0.8.2.ebuild b/x11-misc/bbkeys/bbkeys-0.8.2.ebuild
new file mode 100644
index 000000000000..aa85661b30bb
--- /dev/null
+++ b/x11-misc/bbkeys/bbkeys-0.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.8.2.ebuild,v 1.1 2001/08/29 15:17:38 lamer Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Use keyboard shortcuts in the blackbox wm"
+SRC_URI="http://movingparts.thelinuxcommunity.org/bbkeys/${A}"
+HOMEPAGE="http://movingparts.thelinuxcommunity.org"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbkeys \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r1 b/x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r1
new file mode 100644
index 000000000000..f3422a54e53e
--- /dev/null
+++ b/x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r1
@@ -0,0 +1 @@
+MD5 a8d24c463ea8900c4f5e5fdbc4ee8f9f bbkeys-0.3.6.tar.gz
diff --git a/x11-misc/bbkeys/files/digest-bbkeys-0.8.2 b/x11-misc/bbkeys/files/digest-bbkeys-0.8.2
new file mode 100644
index 000000000000..5016d7965c30
--- /dev/null
+++ b/x11-misc/bbkeys/files/digest-bbkeys-0.8.2
@@ -0,0 +1 @@
+MD5 ce506020fbb17dab286129dcde444ffa bbkeys-0.8.2.tar.gz