summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-11-25 10:32:41 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-11-25 10:32:41 +0000
commit746696756b83fe3ebafb07c0ee8446e8ad8a0a51 (patch)
treef3ad139e89581aa16f3fb12389dcff4a499a0ead /x11-misc/bbppp
parentDrop masks on x11-misc/bbacpi and x11-misc/bbappconf as corresponding bugs we... (diff)
downloadgentoo-2-746696756b83fe3ebafb07c0ee8446e8ad8a0a51.tar.gz
gentoo-2-746696756b83fe3ebafb07c0ee8446e8ad8a0a51.tar.bz2
gentoo-2-746696756b83fe3ebafb07c0ee8446e8ad8a0a51.zip
Fix buffer overflow wrt #439524 by Diego Elio Pettenò <flameeyes@gentoo.org>, drop old, bump to EAPI4
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'x11-misc/bbppp')
-rw-r--r--x11-misc/bbppp/ChangeLog9
-rw-r--r--x11-misc/bbppp/bbppp-0.2.5-r1.ebuild43
-rw-r--r--x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch17
-rw-r--r--x11-misc/bbppp/files/bbppp-gcc3-multiline.diff46
4 files changed, 68 insertions, 47 deletions
diff --git a/x11-misc/bbppp/ChangeLog b/x11-misc/bbppp/ChangeLog
index 2c7c44ae843a..37fca0fdb248 100644
--- a/x11-misc/bbppp/ChangeLog
+++ b/x11-misc/bbppp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/bbppp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbppp/ChangeLog,v 1.19 2012/06/04 19:01:14 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbppp/ChangeLog,v 1.20 2012/11/25 10:32:41 xarthisius Exp $
+
+*bbppp-0.2.5-r1 (25 Nov 2012)
+
+ 25 Nov 2012; Kacper Kowalik <xarthisius@gentoo.org> +bbppp-0.2.5-r1.ebuild,
+ +files/bbppp-0.2.5-overflows.patch, -files/bbppp-gcc3-multiline.diff:
+ Fix buffer overflow wrt #439524 by Diego Elio Pettenò <flameeyes@gentoo.org>,
+ drop old, bump to EAPI4
04 Jun 2012; Michael Weber <xmw@gentoo.org> bbppp-0.2.3.ebuild,
bbppp-0.2.5.ebuild:
diff --git a/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..28c64d0414de
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild,v 1.1 2012/11/25 10:32:41 xarthisius Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox ppp frontend/monitor"
+HOMEPAGE="http://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi"
+
+DOCS=( README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbppp )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc3-multiline.patch \
+ "${FILESDIR}"/${PN}-asneeded.patch \
+ "${FILESDIR}"/${P}-overflows.patch
+ eautoreconf
+}
+
+src_install () {
+ default
+ rm "${D}"/usr/share/bbtools/README.bbppp
+}
+
+pkg_postinst() {
+ # don't assume blackbox exists because virtual/blackbox is installed
+ if [[ -x ${ROOT}/usr/bin/blackbox ]] ; then
+ if ! grep bbppp "${ROOT}"/usr/bin/blackbox &>/dev/null ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+ fi
+}
diff --git a/x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch b/x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch
new file mode 100644
index 000000000000..0c089bc92f4e
--- /dev/null
+++ b/x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch
@@ -0,0 +1,17 @@
+diff --git a/pppstat.cc b/pppstat.cc
+index 71264e4..ca0f11c 100644
+--- a/pppstat.cc
++++ b/pppstat.cc
+@@ -52,10 +52,10 @@ PPPStat::PPPStat(ToolWindow *toolwindow)
+ lastTimeMil = 0.0;
+ ppp_h = -1;
+ #ifndef ISDN
+- active_interface= new char[4];
++ active_interface= new char[5];
+ strcpy(active_interface,"ppp0");
+ #else
+- active_interface= new char[5];
++ active_interface= new char[6];
+ strcpy(active_interface,"ippp0");
+ #endif
+ connect_status=false;
diff --git a/x11-misc/bbppp/files/bbppp-gcc3-multiline.diff b/x11-misc/bbppp/files/bbppp-gcc3-multiline.diff
deleted file mode 100644
index e06a64c1f3a3..000000000000
--- a/x11-misc/bbppp/files/bbppp-gcc3-multiline.diff
+++ /dev/null
@@ -1,46 +0,0 @@
---- main.cc.orig 2001-04-28 05:32:24.000000000 -0500
-+++ main.cc 2004-08-12 17:25:13.727140704 -0500
-@@ -24,26 +24,25 @@
-
- void Usage()
- {
-- char* usageOptions = {"Options:\n\
-- -display <display name> X server to connect to\n\
-- -c[onfig] <filename> Alternate config file\n\
-- -n[obb] Fall back on default configuration\n\
-- -v[ersion] Display version number\n\
-- -h[elp] Display this help\n\
-- -geom[etry] <geometry> Set geometry of window\n\
-- -d[ecorated] Show 'normal' decorated window\n\
-- -w[ithdrawn] Place bbtool in the Slit\n\
-- -s[hape] Don't display groundplate\n\
-- -thru[put] Display throughput rate\n\
-- -o[rient] <v|h> Display window widgets horizontally or vertically\n\
-- -com[pact] Display buttons in compact style\n\
-- -notime Dont display time window\n\
-- -nosecs Show uptime in old-style hh:mm format\n\
-- "};
-+ char* usageOptions = {"Options:\n"
-+ "-display <display name> X server to connect to\n"
-+ "-c[onfig] <filename> Alternate config file\n"
-+ "-n[obb] Fall back on default configuration\n"
-+ "-v[ersion] Display version number\n"
-+ "-h[elp] Display this help\n"
-+ "-geom[etry] <geometry> Set geometry of window\n"
-+ "-d[ecorated] Show 'normal' decorated window\n"
-+ "-w[ithdrawn] Place bbtool in the Slit\n"
-+ "-s[hape] Don't display groundplate\n"
-+ "-thru[put] Display throughput rate\n"
-+ "-o[rient] <v|h> Display window widgets horizontally or vertically\n"
-+ "-com[pact] Display buttons in compact style\n"
-+ "-notime Dont display time window\n"
-+ "-nosecs Show uptime in old-style hh:mm format\n"
-+ };
-
- fprintf(stdout,"\n%s version %s \n",BBTOOL,BBTOOL_VERSION);
-- fprintf(stdout,"Usage:
-- %s [options]\n",BBTOOL);
-+ fprintf(stdout,"Usage:\n%s [options]\n",BBTOOL);
- fprintf(stdout, "%s", usageOptions);
- /*
- fprintf(stdout,"-t[ype] <0|1|2|3> 0: