summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-02-24 01:57:44 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-02-24 01:57:44 +0000
commit45f0f14c61be33806a62741be476609f55695a24 (patch)
treef65221a150c8a8ca92b982d05b6712be16cabb5f /x11-misc/devilspie2
parentx86 stable wrt bug #499832 (diff)
downloadgentoo-2-45f0f14c61be33806a62741be476609f55695a24.tar.gz
gentoo-2-45f0f14c61be33806a62741be476609f55695a24.tar.bz2
gentoo-2-45f0f14c61be33806a62741be476609f55695a24.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/ChangeLog9
-rw-r--r--x11-misc/devilspie2/devilspie2-0.32.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/x11-misc/devilspie2/ChangeLog b/x11-misc/devilspie2/ChangeLog
index fecf0c4a036f..6618bb9ff54a 100644
--- a/x11-misc/devilspie2/ChangeLog
+++ b/x11-misc/devilspie2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/devilspie2
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.12 2013/12/08 15:50:24 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.13 2014/02/24 01:57:44 hasufell Exp $
+
+*devilspie2-0.32 (24 Feb 2014)
+
+ 24 Feb 2014; Julian Ospald <hasufell@gentoo.org> +devilspie2-0.32.ebuild:
+ version bump
08 Dec 2013; Johannes Huber <johu@gentoo.org> devilspie2-0.31.ebuild:
x86 stable, bug #490854
diff --git a/x11-misc/devilspie2/devilspie2-0.32.ebuild b/x11-misc/devilspie2/devilspie2-0.32.ebuild
new file mode 100644
index 000000000000..2f281909e6bd
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.32.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/devilspie2-0.32.ebuild,v 1.1 2014/02/24 01:57:44 hasufell Exp $
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="fi fr ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default folder for scripts is ~/.config/devilspie2/"
+}