summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-04 09:26:19 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-04 09:26:19 +0000
commit7dfb7f2ce9dbc7b83e73d71e13fb16a24d4792a9 (patch)
tree599438d8640aaf4ed04230ac361e0c46b33e13c4 /x11-misc/dragbox/dragbox-0.4.0.ebuild
parentToday's python patches (diff)
downloadgentoo-2-7dfb7f2ce9dbc7b83e73d71e13fb16a24d4792a9.tar.gz
gentoo-2-7dfb7f2ce9dbc7b83e73d71e13fb16a24d4792a9.tar.bz2
gentoo-2-7dfb7f2ce9dbc7b83e73d71e13fb16a24d4792a9.zip
Let it work when python3 is used, by Arfrever bug #373647.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/dragbox/dragbox-0.4.0.ebuild')
-rw-r--r--x11-misc/dragbox/dragbox-0.4.0.ebuild24
1 files changed, 17 insertions, 7 deletions
diff --git a/x11-misc/dragbox/dragbox-0.4.0.ebuild b/x11-misc/dragbox/dragbox-0.4.0.ebuild
index 608b34fcd7e2..4a49847b3eb7 100644
--- a/x11-misc/dragbox/dragbox-0.4.0.ebuild
+++ b/x11-misc/dragbox/dragbox-0.4.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dragbox/dragbox-0.4.0.ebuild,v 1.2 2011/03/28 17:15:55 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dragbox/dragbox-0.4.0.ebuild,v 1.3 2012/03/04 09:26:19 pacho Exp $
-EAPI="2"
+EAPI=4
PYTHON_DEPEND="2"
inherit python
@@ -24,15 +24,25 @@ DEPEND="dev-python/pygtk:2
x11-libs/gtk+:2"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ python_convert_shebangs 2 dragbox
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
}
pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/Dragbox
+ python_mod_optimize Dragbox
}
pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/Dragbox
+ python_mod_cleanup Dragbox
}