summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-07-14 19:12:04 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-07-14 19:12:04 +0000
commit9b1f98eee67a215858f8b7fb2da3b961c9e7e707 (patch)
tree556e3a63b1ab339b169c5d2baae600a4784a9e8a /x11-misc/fraqtive
parentAdd ~sparc (diff)
downloadgentoo-2-9b1f98eee67a215858f8b7fb2da3b961c9e7e707.tar.gz
gentoo-2-9b1f98eee67a215858f8b7fb2da3b961c9e7e707.tar.bz2
gentoo-2-9b1f98eee67a215858f8b7fb2da3b961c9e7e707.zip
Version Bump wrt bug #231536
(Portage version: 2.1.5.2)
Diffstat (limited to 'x11-misc/fraqtive')
-rw-r--r--x11-misc/fraqtive/ChangeLog9
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.3.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/x11-misc/fraqtive/ChangeLog b/x11-misc/fraqtive/ChangeLog
index 818f082560da..ea5b9a8f4cc8 100644
--- a/x11-misc/fraqtive/ChangeLog
+++ b/x11-misc/fraqtive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/fraqtive
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/ChangeLog,v 1.2 2007/01/20 14:54:34 drizzt Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/ChangeLog,v 1.3 2008/07/14 19:12:04 drizzt Exp $
+
+*fraqtive-0.4.3 (14 Jul 2008)
+
+ 14 Jul 2008; Timothy Redaelli <drizzt@gentoo.org> +fraqtive-0.4.3.ebuild:
+ Version Bump wrt bug #231536
20 Jan 2007; Timothy Redaelli <drizzt@gentoo.org> fraqtive-0.3.1.ebuild:
It needs =x11-libs/qt-3* with USE opengl, thanks to Pablo Trabajos wrt bug
diff --git a/x11-misc/fraqtive/fraqtive-0.4.3.ebuild b/x11-misc/fraqtive/fraqtive-0.4.3.ebuild
new file mode 100644
index 000000000000..ae78e614b38a
--- /dev/null
+++ b/x11-misc/fraqtive/fraqtive-0.4.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.3.ebuild,v 1.1 2008/07/14 19:12:04 drizzt Exp $
+
+EAPI=1
+
+inherit qt4
+
+DESCRIPTION="Fraqtive is a KDE-based program for interactively drawing Mandelbrot and Julia fractals"
+HOMEPAGE="http://fraqtive.mimec.org/"
+SRC_URI="mirror://sourceforge/fraqtive/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse2"
+
+DEPENDS="|| ( ( x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-opengl )
+ >=x11-libs/qt:4 )"
+
+QT4_BUILT_WITH_USE_CHECK="opengl"
+
+src_unpack() {
+ local conf="release"
+
+ if use sse2; then
+ conf="$conf sse2"
+ else
+ conf="$conf no-sse2"
+ fi
+
+ unpack ${A}
+
+ echo "CONFIG += $conf" > "${S}"/config.pri
+ echo "PREFIX = /usr" >> "${S}"/config.pri
+}
+
+src_compile() {
+ eqmake4
+ emake || die "make failed"
+}
+
+src_install() {
+ make install INSTALL_ROOT="${D}" || die "install failed"
+}