summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-04-12 20:42:53 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-04-12 20:42:53 +0000
commit948ac998e85ad2e91af798e8fcf1751425625971 (patch)
tree63174d2f4486329243191cc905d92a68ec45e41c /x11-misc/icewmcp
parenthad the arguements to replace-cpu-flags swapped for hppa (diff)
downloadgentoo-2-948ac998e85ad2e91af798e8fcf1751425625971.tar.gz
gentoo-2-948ac998e85ad2e91af798e8fcf1751425625971.tar.bz2
gentoo-2-948ac998e85ad2e91af798e8fcf1751425625971.zip
Initial import. Closing bug #42448.
Diffstat (limited to 'x11-misc/icewmcp')
-rw-r--r--x11-misc/icewmcp/ChangeLog10
-rw-r--r--x11-misc/icewmcp/Manifest2
-rw-r--r--x11-misc/icewmcp/files/digest-icewmcp-3.11
-rw-r--r--x11-misc/icewmcp/icewmcp-3.1.ebuild54
-rw-r--r--x11-misc/icewmcp/metadata.xml5
5 files changed, 72 insertions, 0 deletions
diff --git a/x11-misc/icewmcp/ChangeLog b/x11-misc/icewmcp/ChangeLog
new file mode 100644
index 000000000000..e384e7f0516b
--- /dev/null
+++ b/x11-misc/icewmcp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/icewmcp
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/ChangeLog,v 1.1 2004/04/12 20:42:53 pyrania Exp $
+
+*icewmcp-3.1 (12 Apr 2004)
+
+ 12 Apr 2004; Markus Nigbur <pyrania@gentoo.org> icewmcp-3.1.ebuild,
+ metadata.xml:
+ Initial import. Closing bug #42448.
+
diff --git a/x11-misc/icewmcp/Manifest b/x11-misc/icewmcp/Manifest
new file mode 100644
index 000000000000..c36a21adf8f4
--- /dev/null
+++ b/x11-misc/icewmcp/Manifest
@@ -0,0 +1,2 @@
+MD5 e894b290c91a39ae55e7df15e03c5320 icewmcp-3.1.ebuild 2305
+MD5 2180d0e3edcb1dd9b00cb79e2f1d951d files/digest-icewmcp-3.1 74
diff --git a/x11-misc/icewmcp/files/digest-icewmcp-3.1 b/x11-misc/icewmcp/files/digest-icewmcp-3.1
new file mode 100644
index 000000000000..c530980e36ac
--- /dev/null
+++ b/x11-misc/icewmcp/files/digest-icewmcp-3.1
@@ -0,0 +1 @@
+MD5 6f862cfa70b1468fc3e4ef5fd1ffe18c IceWMControlPanel-3.1.tar.bz2 571832
diff --git a/x11-misc/icewmcp/icewmcp-3.1.ebuild b/x11-misc/icewmcp/icewmcp-3.1.ebuild
new file mode 100644
index 000000000000..cfcb0ec46675
--- /dev/null
+++ b/x11-misc/icewmcp/icewmcp-3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/icewmcp-3.1.ebuild,v 1.1 2004/04/12 20:42:53 pyrania Exp $
+
+S=${WORKDIR}/INSTALL-IceWMCP
+MY_PN=IceWMControlPanel
+MY_DEST=usr/lib/${P}
+MY_BIN=usr/bin
+
+DESCRIPTION="A complete control panel for IceWM using gtk & python"
+HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
+SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="x11-wm/icewm
+ >=dev-python/pygtk-1.99
+ >=x11-libs/gtk+-2.0.0
+ >=dev-lang/python-2.2"
+
+src_install() {
+ dodir ${MY_DEST}/
+ dodir ${MY_BIN}/
+ dodoc ${S}/doc/* ${S}/licenses/*
+ cp ${S}/* ${D}/${MY_DEST}
+ cp -R ${S}/applets ${S}/applet-icons ${S}/help ${S}/icons ${S}/locale ${S}/pixmaps ${D}/${MY_DEST}/
+ # create executable shortcuts to the python scripts
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP.py" > ${T}/IceWMCP
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPKeyboard.py" > ${T}/IceWMCP-Keyboard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPMouse.py" > ${T}/IceWMCP-Mouse
+ echo -e "#!/bin/bash \n python /${MY_DEST}/pyspool.py" > ${T}/IceWMCP-PySpool
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWallpaper.py" > ${T}/IceWMCP-Wallpaper
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWinOptions.py" > ${T}/IceWMCP-WinOptions
+ echo -e "#!/bin/bash \n python /${MY_DEST}/phrozenclock.py" > ${T}/PhrozenClock
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icesound.py" > ${T}/IceSoundManager
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP_GtkPCCard.py" > ${T}/GtkPCCard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceMe.py" > ${T}/iceme
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref.py" > ${T}/icepref
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref_td.py" > ${T}/icepref_td
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPGtkIconSelection.py" > ${T}/IceWMCP-Icons
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPEnergyStar.py" > ${T}/IceWMCP-EnergyStar
+ dobin ${T}/*
+}
+
+pkg_postinst() {
+ einfo "Some of the icons displayed by IceWMCP may be pointing to"
+ einfo "programs which are not on your system! You can hide them"
+ einfo "using the Configuration window (Ctrl+C) or change them"
+ einfo "by editing the files in"
+ einfo "/${MY_DEST}/applets and"
+ einfo "/${MY_DEST}/applet-icons."
+}
diff --git a/x11-misc/icewmcp/metadata.xml b/x11-misc/icewmcp/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-misc/icewmcp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>