summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-27 15:23:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-27 15:23:04 +0000
commitbb66331fcd7d8140f3601c943ca90fde2368bd49 (patch)
tree7a9b9082d13126753b78ff2f2620b78a64e797ad /x11-misc/rednotebook
parentvmware-tools moved from overlay (diff)
downloadgentoo-2-bb66331fcd7d8140f3601c943ca90fde2368bd49.tar.gz
gentoo-2-bb66331fcd7d8140f3601c943ca90fde2368bd49.tar.bz2
gentoo-2-bb66331fcd7d8140f3601c943ca90fde2368bd49.zip
Version bump. Bug #360707
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog10
-rw-r--r--x11-misc/rednotebook/files/rednotebook-1.1.4-disable-webkit.patch18
-rw-r--r--x11-misc/rednotebook/metadata.xml5
-rw-r--r--x11-misc/rednotebook/rednotebook-1.1.4.ebuild32
4 files changed, 58 insertions, 7 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 43ec4cc96737..b04e7831991e 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.43 2010/12/30 13:04:32 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.44 2011/03/27 15:23:04 hwoarang Exp $
+
+*rednotebook-1.1.4 (27 Mar 2011)
+
+ 27 Mar 2011; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.1.4.ebuild,
+ +files/rednotebook-1.1.4-disable-webkit.patch, metadata.xml:
+ Version bump. Bug #360707
*rednotebook-1.1.2 (30 Dec 2010)
diff --git a/x11-misc/rednotebook/files/rednotebook-1.1.4-disable-webkit.patch b/x11-misc/rednotebook/files/rednotebook-1.1.4-disable-webkit.patch
new file mode 100644
index 000000000000..2addeb6482bd
--- /dev/null
+++ b/x11-misc/rednotebook/files/rednotebook-1.1.4-disable-webkit.patch
@@ -0,0 +1,18 @@
+Index: rednotebook-1.1.4/rednotebook/gui/browser.py
+===================================================================
+--- rednotebook-1.1.4.orig/rednotebook/gui/browser.py
++++ rednotebook-1.1.4/rednotebook/gui/browser.py
+@@ -40,13 +40,6 @@ from rednotebook.util import filesystem
+
+
+ webkit = None
+-try:
+- import webkit
+-except ImportError:
+- logging.error('Webkit was not found. It can be found in a package '
+- 'with the name python-webkit or pywebkitgtk. ')
+- sys.exit(1)
+-
+
+ def can_print_pdf():
+ if not webkit:
diff --git a/x11-misc/rednotebook/metadata.xml b/x11-misc/rednotebook/metadata.xml
index 2a8c24e65dda..4f7615692829 100644
--- a/x11-misc/rednotebook/metadata.xml
+++ b/x11-misc/rednotebook/metadata.xml
@@ -10,11 +10,6 @@
<email>hwoarang@gentoo.org</email>
<name>Markos Chandras</name>
</maintainer>
-<maintainer>
-<email>nightmorph@gentoo.org</email>
-<name>Josh Saddler</name>
-<description>Proxy maintainer</description>
-</maintainer>
<longdescription lang="en">
</longdescription>
</pkgmetadata>
diff --git a/x11-misc/rednotebook/rednotebook-1.1.4.ebuild b/x11-misc/rednotebook/rednotebook-1.1.4.ebuild
new file mode 100644
index 000000000000..1bd05b862171
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.1.4.ebuild,v 1.1 2011/03/27 15:23:04 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${P}-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-1.1.0-disable-spell.patch"
+ distutils_src_prepare
+}