summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-12 20:53:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-12 20:53:59 +0000
commitceca9b3ab89310ee78daf0d631e7282b978556bc (patch)
tree38d6b7fa4e19100b14b969fb4e115f26220ba4bb /x11-misc/rednotebook
parentBug #365871 (diff)
downloadgentoo-2-ceca9b3ab89310ee78daf0d631e7282b978556bc.tar.gz
gentoo-2-ceca9b3ab89310ee78daf0d631e7282b978556bc.tar.bz2
gentoo-2-ceca9b3ab89310ee78daf0d631e7282b978556bc.zip
Version bump
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog7
-rw-r--r--x11-misc/rednotebook/rednotebook-1.1.6.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 76d0d31c021e..6d9f91f6082f 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.45 2011/04/06 20:19:22 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.46 2011/05/12 20:53:59 hwoarang Exp $
+
+*rednotebook-1.1.6 (12 May 2011)
+
+ 12 May 2011; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.1.6.ebuild:
+ Version bump
06 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
rednotebook-1.1.1.ebuild, rednotebook-1.1.2.ebuild, rednotebook-1.1.4.ebuild:
diff --git a/x11-misc/rednotebook/rednotebook-1.1.6.ebuild b/x11-misc/rednotebook/rednotebook-1.1.6.ebuild
new file mode 100644
index 000000000000..7f1c3e19181b
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.1.6.ebuild,v 1.1 2011/05/12 20:53:59 hwoarang Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${PN}-1.1.4-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-1.1.0-disable-spell.patch"
+ distutils_src_prepare
+}