summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-02-02 23:09:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-02-02 23:09:11 +0000
commitdfdbe979dbe4ed06241e6e8b6e2412cd32fe9ab6 (patch)
tree4899125082bb5c79ab227554aae908d1b05135c7 /x11-misc/rednotebook
parentpunt (diff)
downloadgentoo-2-dfdbe979dbe4ed06241e6e8b6e2412cd32fe9ab6.tar.gz
gentoo-2-dfdbe979dbe4ed06241e6e8b6e2412cd32fe9ab6.tar.bz2
gentoo-2-dfdbe979dbe4ed06241e6e8b6e2412cd32fe9ab6.zip
version bump. use linguas_x to select desired translations
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog7
-rw-r--r--x11-misc/rednotebook/rednotebook-1.3.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 9d003e8986a3..339fb75e9c9b 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.55 2012/01/28 15:00:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.56 2012/02/02 23:09:11 hwoarang Exp $
+
+*rednotebook-1.3.0 (02 Feb 2012)
+
+ 02 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.3.0.ebuild:
+ version bump. use linguas_x to select desired translations
28 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
rednotebook-1.2.0.ebuild:
diff --git a/x11-misc/rednotebook/rednotebook-1.3.0.ebuild b/x11-misc/rednotebook/rednotebook-1.3.0.ebuild
new file mode 100644
index 000000000000..29f64804e783
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.3.0.ebuild,v 1.1 2012/02/02 23:09:11 hwoarang Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+LANGS="ar ast be bg bs ca cs cy da de el en_GB eo es eu fi fo fr gl he hr hu hy
+id it ja ka kk ko lt mn ms nb nds nl nn oc pl pt pt_BR ro ru si sk sr sv ta te
+tl tr ug uk uz vi wa zh_CN zh_HK zh_TW"
+
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell"
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ dev-python/pywebkitgtk
+ spell? ( dev-python/gtkspell-python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${P}-disable-spell.patch"
+ # rename wae file. I think this should be wa.po instead of wae.po
+ mv po/wae.po po/wa.po || die
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm po/${x}.po || die
+ fi
+ done
+ distutils_src_prepare
+}