summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-07-18 10:10:10 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-07-18 10:10:10 +0000
commitb66095bd40db903979063c37e2187c6b4bb00991 (patch)
tree34858a781b9713d25974382ff7cc6b57391d73eb /x11-misc/set_opacity
parentFixed dependencies; this needs curl[gnutls] (diff)
downloadgentoo-2-b66095bd40db903979063c37e2187c6b4bb00991.tar.gz
gentoo-2-b66095bd40db903979063c37e2187c6b4bb00991.tar.bz2
gentoo-2-b66095bd40db903979063c37e2187c6b4bb00991.zip
Add x11-misc/set_opacity-1.0, bug #276913
(Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'x11-misc/set_opacity')
-rw-r--r--x11-misc/set_opacity/ChangeLog11
-rw-r--r--x11-misc/set_opacity/files/makefile.patch21
-rw-r--r--x11-misc/set_opacity/metadata.xml12
-rw-r--r--x11-misc/set_opacity/set_opacity-1.0.ebuild34
4 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/set_opacity/ChangeLog b/x11-misc/set_opacity/ChangeLog
new file mode 100644
index 000000000000..1b6c47a59b8a
--- /dev/null
+++ b/x11-misc/set_opacity/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/set_opacity
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/ChangeLog,v 1.1 2011/07/18 10:10:10 maksbotan Exp $
+
+*set_opacity-1.0 (18 Jul 2011)
+
+ 18 Jul 2011; Maxim Koltsov (maksbotan) <maksbotan@gentoo.org>
+ +set_opacity-1.0.ebuild, +files/makefile.patch, +metadata.xml:
+ Added ebuild for 1.0 version with pinkbyte@mail.ru as maintainer, bug
+ #276913
+
diff --git a/x11-misc/set_opacity/files/makefile.patch b/x11-misc/set_opacity/files/makefile.patch
new file mode 100644
index 000000000000..bb21db68ce48
--- /dev/null
+++ b/x11-misc/set_opacity/files/makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile 2006-02-09 16:45:52.000000000 +0300
++++ Makefile 2011-07-18 13:58:58.644703015 +0400
+@@ -1,14 +1,14 @@
+ PACKAGES = xcomposite xfixes xdamage xrender
+-LIBS=`pkg-config --libs ${PACKAGES}` -lm
+-INCS=`pkg-config --cflags ${PACKAGES}`
++LIBS=$(shell pkg-config --libs $(PACKAGES)) -lm
++INCS=$(shell pkg-config --cflags $(PACKAGES))
+
+ .c.o:
+- $(CC) $(CFLAGS) $(INCS) -c $*.c
++ $(CC) $(CFLAGS) $(INCS) -c $< -o $@
+
+ OBJS=set_opacity.o interface.o stack.o
+
+ set_opacity: $(OBJS)
+- $(CC) $(CFLAGS) -g -o $@ $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ $(OBJS): interface.h stack.h
+
diff --git a/x11-misc/set_opacity/metadata.xml b/x11-misc/set_opacity/metadata.xml
new file mode 100644
index 000000000000..5fd1092e6a78
--- /dev/null
+++ b/x11-misc/set_opacity/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <description>Proxy maintainer</description>
+</maintainer>
+<maintainer>
+ <email>pinkbyte@mail.ru</email>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-misc/set_opacity/set_opacity-1.0.ebuild b/x11-misc/set_opacity/set_opacity-1.0.ebuild
new file mode 100644
index 000000000000..995d9601aa58
--- /dev/null
+++ b/x11-misc/set_opacity/set_opacity-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/set_opacity-1.0.ebuild,v 1.1 2011/07/18 10:10:10 maksbotan Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
+HOMEPAGE="http://www.xvilka.narod.ru/downloads.xhtml"
+SRC_URI="http://www.xvilka.narod.ru/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXdamage
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND=${DEPEND}
+
+src_prepare(){
+ epatch "${FILESDIR}"/makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin set_opacity || die "dobin failed"
+}