summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-06-20 18:59:09 +0000
committerAron Griffis <agriffis@gentoo.org>2003-06-20 18:59:09 +0000
commit5157f7828be7c38019f47c32f3cc51d0467e927e (patch)
tree6060842b4cc742ef7b67432358bbf609090a1d36 /x11-misc/xcb
parentnew ebuild for this excellent X utility (diff)
downloadgentoo-2-5157f7828be7c38019f47c32f3cc51d0467e927e.tar.gz
gentoo-2-5157f7828be7c38019f47c32f3cc51d0467e927e.tar.bz2
gentoo-2-5157f7828be7c38019f47c32f3cc51d0467e927e.zip
new ebuild for this excellent X utility
Diffstat (limited to 'x11-misc/xcb')
-rw-r--r--x11-misc/xcb/ChangeLog9
-rw-r--r--x11-misc/xcb/Manifest3
-rw-r--r--x11-misc/xcb/files/digest-xcb-2.41
-rw-r--r--x11-misc/xcb/xcb-2.4.ebuild44
4 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/xcb/ChangeLog b/x11-misc/xcb/ChangeLog
new file mode 100644
index 000000000000..2b06cf29295b
--- /dev/null
+++ b/x11-misc/xcb/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/xcb
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcb/ChangeLog,v 1.1 2003/06/20 18:59:03 agriffis Exp $
+
+*xcb-2.4 (20 Jun 2003)
+
+ 20 Jun 2003; Aron Griffis <agriffis@gentoo.org> xcb-2.4.ebuild:
+ New ebuild for this excellent X utility
+
diff --git a/x11-misc/xcb/Manifest b/x11-misc/xcb/Manifest
index bb59c97dfc97..3f34f0975ef5 100644
--- a/x11-misc/xcb/Manifest
+++ b/x11-misc/xcb/Manifest
@@ -1,2 +1,3 @@
-MD5 21a32f81ee96bceeca52c97f90f32c69 xcb-2.4.ebuild 2532
+MD5 48ca3998f086c9a7ced3a7ab9d43b6e4 xcb-2.4.ebuild 1040
+MD5 65b06e702546771d3d2b8bd1f669f3c8 ChangeLog 341
MD5 297f269db8ac3e4c928e489e95c0d07e files/digest-xcb-2.4 58
diff --git a/x11-misc/xcb/files/digest-xcb-2.4 b/x11-misc/xcb/files/digest-xcb-2.4
new file mode 100644
index 000000000000..8fecef967529
--- /dev/null
+++ b/x11-misc/xcb/files/digest-xcb-2.4
@@ -0,0 +1 @@
+MD5 bc791ccefd9260394a8f30733adc42e4 xcb-2.4.tar.gz 19830
diff --git a/x11-misc/xcb/xcb-2.4.ebuild b/x11-misc/xcb/xcb-2.4.ebuild
new file mode 100644
index 000000000000..1ed66bec9670
--- /dev/null
+++ b/x11-misc/xcb/xcb-2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcb/xcb-2.4.ebuild,v 1.1 2003/06/20 18:59:03 agriffis Exp $
+
+DESCRIPTION="Marc Lehmann's improved X Cut Buffers"
+HOMEPAGE="http://www.goof.com/pcg/marc/xcb.html"
+SRC_URI="http://www.goof.com/pcg/marc/data/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha"
+IUSE="motif"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's/^CFLAGS.=/CFLAGS +=/' Makefile.std || die 'sed failed'
+ mv xcb.man xcb.1 || die 'mv failed'
+}
+
+src_compile() {
+ local gui libs
+
+ if use motif; then
+ gui="-DMOTIF"
+ libs="-L/usr/X11R6/lib -lXm -lXt -lX11"
+ else
+ gui="-DATHENA"
+ libs="-L/usr/X11R6/lib -lXaw -lXt -lXext -lX11"
+ fi
+
+ emake -f Makefile.std xcb Xcb.ad \
+ CFLAGS="${CFLAGS} ${gui} -I/usr/X11R6/include" \
+ GUI="${gui}" \
+ LIBS="${libs}" \
+ || die 'emake failed'
+}
+
+src_install() {
+ dobin xcb
+ doman xcb.1
+ insinto /usr/X11R6/lib/X11/app-defaults ; newins Xcb.ad Xcb
+}