summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-10-11 09:29:01 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-10-11 09:29:01 +0000
commita0064ba7be5908f908829e973094ba650c7b635d (patch)
treeb8e70d14f1d7c192886ab1971b5c6bd9157f9952 /x11-misc/xcompmgr/xcompmgr-1.1.ebuild
parentPATCH_VER 0.2.3. Add 9910_all_use-nonow-ldflag-for-hardenedgccspecs.patch. In... (diff)
downloadgentoo-2-a0064ba7be5908f908829e973094ba650c7b635d.tar.gz
gentoo-2-a0064ba7be5908f908829e973094ba650c7b635d.tar.bz2
gentoo-2-a0064ba7be5908f908829e973094ba650c7b635d.zip
A real release, albeit hard to find (#65620). Ebuild fixes are from Adam Jackson <ajax@nwnk.net>.
Diffstat (limited to 'x11-misc/xcompmgr/xcompmgr-1.1.ebuild')
-rw-r--r--x11-misc/xcompmgr/xcompmgr-1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/xcompmgr/xcompmgr-1.1.ebuild b/x11-misc/xcompmgr/xcompmgr-1.1.ebuild
new file mode 100644
index 000000000000..800e7ce9d06f
--- /dev/null
+++ b/x11-misc/xcompmgr/xcompmgr-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="X Compositing manager"
+HOMEPAGE="http://freedesktop.org/Software/xapps"
+SRC_URI="http://freedesktop.org/~xapps/release/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+RDEPEND=">=x11-base/xorg-x11-6.8.0"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.5
+ dev-util/pkgconfig"
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+ ./autogen.sh || die
+ econf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog
+}