summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 12:53:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 12:53:13 +0000
commit9402a277ba1cbe575e1f828984e5ee6d0e7962ba (patch)
tree29a51dbf46dfb207cf2eb0dea328ba3fb4999845 /x11-misc/xfe
parentremoved old versions (diff)
downloadgentoo-2-9402a277ba1cbe575e1f828984e5ee6d0e7962ba.tar.gz
gentoo-2-9402a277ba1cbe575e1f828984e5ee6d0e7962ba.tar.bz2
gentoo-2-9402a277ba1cbe575e1f828984e5ee6d0e7962ba.zip
Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #278101.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/ChangeLog8
-rw-r--r--x11-misc/xfe/files/xfe-1.19.2-gcc44.patch12
-rw-r--r--x11-misc/xfe/xfe-1.19.2.ebuild21
3 files changed, 31 insertions, 10 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index a76b911886b9..d15d82373914 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xfe
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.49 2008/10/04 12:01:45 mabi Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.50 2009/08/05 12:53:13 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> xfe-1.19.2.ebuild,
+ +files/xfe-1.19.2-gcc44.patch:
+ Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #278101.
*xfe-1.19.2 (04 Oct 2008)
diff --git a/x11-misc/xfe/files/xfe-1.19.2-gcc44.patch b/x11-misc/xfe/files/xfe-1.19.2-gcc44.patch
new file mode 100644
index 000000000000..36165810b310
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.19.2-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur xfe-1.19.2.orig/src/ViewWindow.cpp xfe-1.19.2/src/ViewWindow.cpp
+--- xfe-1.19.2.orig/src/ViewWindow.cpp 2008-07-17 16:13:18.000000000 +0300
++++ xfe-1.19.2/src/ViewWindow.cpp 2009-08-05 15:51:36.000000000 +0300
+@@ -655,7 +655,7 @@
+ {
+ FXString buf=viewer->getText();
+ const char* text=buf.text();
+- char *p = strstr(&text[pos],str.text());
++ const char *p = strstr(&text[pos],str.text());
+ if(!p)
+ return -1;
+ return (p-text);
diff --git a/x11-misc/xfe/xfe-1.19.2.ebuild b/x11-misc/xfe/xfe-1.19.2.ebuild
index 6db225229ff5..b082d95ff520 100644
--- a/x11-misc/xfe/xfe-1.19.2.ebuild
+++ b/x11-misc/xfe/xfe-1.19.2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.19.2.ebuild,v 1.1 2008/10/04 12:01:45 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.19.2.ebuild,v 1.2 2009/08/05 12:53:13 ssuominen Exp $
EAPI=2
-
inherit eutils
DESCRIPTION="MS-Explorer-like minimalist file manager for X"
@@ -15,16 +14,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug nls +png"
-DEPEND="=x11-libs/fox-1.6*[truetype,png?]
+RDEPEND="=x11-libs/fox-1.6*[truetype,png?]"
+DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_compile() {
- econf $(use_enable nls) $(use_enable debug)
- emake || die "emake failed."
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS BUGS ChangeLog README TODO
make_desktop_entry xfe "X File Explorer" xfe "System;FileTools;FileManager"
make_desktop_entry xfi "X File Image" xfi "System;FileTools"