summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-09-03 14:31:39 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-09-03 14:31:39 +0000
commit45d5738e4a44ff992b02eb76b4615591c8a8ab56 (patch)
treed1d585b33101264218e24a543af97a237f668f2f /x11-misc/xkeyboard-config
parentStable on ia64. (diff)
downloadgentoo-2-45d5738e4a44ff992b02eb76b4615591c8a8ab56.tar.gz
gentoo-2-45d5738e4a44ff992b02eb76b4615591c8a8ab56.tar.bz2
gentoo-2-45d5738e4a44ff992b02eb76b4615591c8a8ab56.zip
Add missing LSGT symbol to evdev symbols. (Dennis Schridde, Bug #145097)
This should fix the availability of <, > and | for users of this symbol list. (Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog9
-rw-r--r--x11-misc/xkeyboard-config/files/add_missing_lsgt.patch10
-rw-r--r--x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.8-r13
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-0.8-r1.ebuild63
4 files changed, 84 insertions, 1 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index a579fabba6a6..8a70bd352a22 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.21 2006/08/16 18:06:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.22 2006/09/03 14:31:39 joshuabaergen Exp $
+
+*xkeyboard-config-0.8-r1 (03 Sep 2006)
+
+ 03 Sep 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/add_missing_lsgt.patch, +xkeyboard-config-0.8-r1.ebuild:
+ Add missing LSGT symbol to evdev symbols. (Dennis Schridde, Bug #145097)
+ This should fix the availability of <, > and | for users of this symbol list.
16 Aug 2006; Brent Baude <ranger@gentoo.org> xkeyboard-config-0.8.ebuild:
Keywording ppc64 stable per MrBones request
diff --git a/x11-misc/xkeyboard-config/files/add_missing_lsgt.patch b/x11-misc/xkeyboard-config/files/add_missing_lsgt.patch
new file mode 100644
index 000000000000..0f1f3752acbd
--- /dev/null
+++ b/x11-misc/xkeyboard-config/files/add_missing_lsgt.patch
@@ -0,0 +1,10 @@
+--- keycodes/evdev 2006/02/21 23:55:01 1.1
++++ keycodes/evdev 2006/04/19 23:56:39 1.2
+@@ -346,6 +346,7 @@
+ // <META> = 156; // <I1C>
+ // <SUPR> = 127; // <U7F>
+ // <HYPR> = 128; // <U80>
++ <LSGT> = 94;
+
+ indicator 1 = "Caps Lock";
+ indicator 2 = "Num Lock";
diff --git a/x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.8-r1 b/x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.8-r1
new file mode 100644
index 000000000000..5e692d8ed9bc
--- /dev/null
+++ b/x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.8-r1
@@ -0,0 +1,3 @@
+MD5 48e694ebe816065670dda2a36f0581a2 xkeyboard-config-0.8.tar.bz2 410194
+RMD160 f870d34f97c677a542fd953e3767b9516d10347c xkeyboard-config-0.8.tar.bz2 410194
+SHA256 55994318727ecdb61a7937862a87262b32c3655e2a39fb50cff514fb92793abb xkeyboard-config-0.8.tar.bz2 410194
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-0.8-r1.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-0.8-r1.ebuild
new file mode 100644
index 000000000000..1adec65f7d07
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-0.8-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8-r1.ebuild,v 1.1 2006/09/03 14:31:39 joshuabaergen Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="X keyboard configuration database"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~x86 ~x86-fbsd"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+SRC_URI="http://xlibs.freedesktop.org/xkbdesc/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="x11-apps/xkbcomp
+ !x11-misc/xkbdata"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser"
+
+pkg_setup() {
+ # (#130590) The old XKB directory can screw stuff up
+ local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
+ if [[ -d ${DIR} ]] ; then
+ eerror "Directory ${DIR} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${DIR}"
+ fi
+
+ # The old xkbdata 'pc' directory can screw stuff up, because portage won't
+ # let us overwrite a directory with a file
+ local PC="${ROOT}usr/share/X11/xkb/symbols/pc"
+ if [[ -d ${PC} ]] ; then
+ eerror "Directory ${PC} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${PC}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # bug #145097
+ epatch "${FILESDIR}/add_missing_lsgt.patch"
+}
+
+src_compile() {
+ econf \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --enable-compat-rules \
+ --disable-xkbcomp-symlink \
+ --with-xkb-rules-symlink=xorg \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ echo "CONFIG_PROTECT=\"/usr/share/X11/xkb\"" > "${T}"/10xkeyboard-config
+ doenvd "${T}"/10xkeyboard-config
+}