summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-07-14 21:36:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-07-14 21:36:06 +0000
commit542c306d0e6a8b4ddd2ea553dfdaae76bb2a03c4 (patch)
treea5d4d559e7126bc4fae8fabe50d7f79a1ac478e3 /x11-misc/xmobar
parentversion bump (diff)
downloadgentoo-2-542c306d0e6a8b4ddd2ea553dfdaae76bb2a03c4.tar.gz
gentoo-2-542c306d0e6a8b4ddd2ea553dfdaae76bb2a03c4.tar.bz2
gentoo-2-542c306d0e6a8b4ddd2ea553dfdaae76bb2a03c4.zip
Allow mtl-2.2 (bug #517068 by Adam Stylinski).
(Portage version: 2.2.10_p15/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'x11-misc/xmobar')
-rw-r--r--x11-misc/xmobar/ChangeLog7
-rw-r--r--x11-misc/xmobar/xmobar-0.20.1-r1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/x11-misc/xmobar/ChangeLog b/x11-misc/xmobar/ChangeLog
index 63e8ae7a6dec..52990a830cbb 100644
--- a/x11-misc/xmobar/ChangeLog
+++ b/x11-misc/xmobar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xmobar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.27 2014/05/10 11:57:28 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.28 2014/07/14 21:36:06 slyfox Exp $
+
+*xmobar-0.20.1-r1 (14 Jul 2014)
+
+ 14 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> +xmobar-0.20.1-r1.ebuild:
+ Allow mtl-2.2 (bug #517068 by Adam Stylinski).
10 May 2014; Sergei Trofimovich <slyfox@gentoo.org> xmobar-0.20.1.ebuild:
Drop needless mpd depend.
diff --git a/x11-misc/xmobar/xmobar-0.20.1-r1.ebuild b/x11-misc/xmobar/xmobar-0.20.1-r1.ebuild
new file mode 100644
index 000000000000..feaaa113da1e
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.20.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.20.1-r1.ebuild,v 1.1 2014/07/14 21:36:06 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -all_extensions,+with_threaded,+with_utf8,with_iwlib:wifi,with_alsa:alsa,with_xft:xft,with_datezone:timezone,with_dbus:dbus,with_mpd:mpd,with_inotify:inotify,with_mpris:mpris
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://projects.haskell.org/xmobar/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus inotify mpd mpris timezone wifi xft"
+
+RDEPEND="x11-libs/libXrandr
+ wifi? ( net-wireless/wireless-tools )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ >=dev-haskell/http-4000
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-2.3
+ >=dev-haskell/parsec-3.1 <dev-haskell/parsec-3.2
+ dev-haskell/regex-compat
+ >=dev-haskell/stm-2.3 <dev-haskell/stm-2.5
+ >=dev-haskell/utf8-string-0.3 <dev-haskell/utf8-string-0.4
+ >=dev-haskell/x11-1.6.1
+ >=dev-lang/ghc-6.12.1
+ alsa? ( >=dev-haskell/alsa-core-0.5 <dev-haskell/alsa-core-0.6
+ >=dev-haskell/alsa-mixer-0.2 <dev-haskell/alsa-mixer-0.3 )
+ dbus? ( >=dev-haskell/dbus-0.10 )
+ inotify? ( >=dev-haskell/hinotify-0.3 <dev-haskell/hinotify-0.4 )
+ mpd? ( >=dev-haskell/libmpd-0.8 <dev-haskell/libmpd-0.9 )
+ mpris? ( >=dev-haskell/dbus-0.10 )
+ timezone? ( >=dev-haskell/timezone-olson-0.1 <dev-haskell/timezone-olson-0.2
+ >=dev-haskell/timezone-series-0.1 <dev-haskell/timezone-series-0.2 )
+ xft? ( >=dev-haskell/x11-xft-0.2 <dev-haskell/x11-xft-0.4 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'mtl >= 2.0 && < 2.2' 'mtl >= 2.0 && < 2.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-all_extensions \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag timezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ $(cabal_flag inotify with_inotify) \
+ $(cabal_flag wifi with_iwlib) \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ --flag=with_threaded \
+ --flag=with_utf8 \
+ $(cabal_flag xft with_xft)
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc samples/xmobar.config readme.md news.md
+}