summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-11-26 21:46:11 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-11-26 21:46:11 +0000
commitffd50305065045ffa7aa77a1763fa9abf1b52418 (patch)
tree0a62268752b984e8d4171cec5dff62269c429727 /x11-misc/xmobar
parentRemove unneeded dependency from dev-haskell/x11-xft. (diff)
downloadgentoo-2-ffd50305065045ffa7aa77a1763fa9abf1b52418.tar.gz
gentoo-2-ffd50305065045ffa7aa77a1763fa9abf1b52418.tar.bz2
gentoo-2-ffd50305065045ffa7aa77a1763fa9abf1b52418.zip
Version bump x11-misc/xmobar.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xmobar')
-rw-r--r--x11-misc/xmobar/ChangeLog9
-rw-r--r--x11-misc/xmobar/metadata.xml3
-rw-r--r--x11-misc/xmobar/xmobar-0.9.2-r1.ebuild59
3 files changed, 69 insertions, 2 deletions
diff --git a/x11-misc/xmobar/ChangeLog b/x11-misc/xmobar/ChangeLog
index 0a5af33f3596..437ee7eaa65a 100644
--- a/x11-misc/xmobar/ChangeLog
+++ b/x11-misc/xmobar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xmobar
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.3 2008/09/24 06:11:46 kolmodin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.4 2009/11/26 21:46:11 kolmodin Exp $
+
+*xmobar-0.9.2-r1 (26 Nov 2009)
+
+ 26 Nov 2009; <kolmodin@gentoo.org> +xmobar-0.9.2-r1.ebuild, metadata.xml:
+ Version bump.
*xmobar-0.9 (24 Sep 2008)
diff --git a/x11-misc/xmobar/metadata.xml b/x11-misc/xmobar/metadata.xml
index 8c66906af531..050435d7e32c 100644
--- a/x11-misc/xmobar/metadata.xml
+++ b/x11-misc/xmobar/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
+<use>
+ <flag name='mail'>Support the mail plugin. Pulls dependency dev-haskell/hinotify.</flag>
+</use>
</pkgmetadata>
diff --git a/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild b/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..b95141a439f9
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild,v 1.1 2009/11/26 21:46:11 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://code.haskell.org/~arossato/xmobar"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 -sparc ~x86"
+IUSE="xft unicode mail"
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/filepath
+ dev-haskell/mtl
+ dev-haskell/parsec
+ dev-haskell/stm
+ unicode? ( dev-haskell/utf8-string )
+ xft? ( dev-haskell/utf8-string
+ dev-haskell/x11-xft )
+ mail? ( dev-haskell/hinotify )"
+RDEPEND="${DEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${P}-*")
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--constraint=base<4"
+
+ if use xft; then
+ CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=with_xft"
+ else
+ CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=-with_xft"
+ fi
+
+ if use unicode; then
+ CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=with_utf8"
+ else
+ CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=-with_utf8"
+ fi
+
+ if use mail; then
+ CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=with_inotify"
+ else
+ CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=-with_inotify"
+ fi
+
+ cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc xmobar.config-sample README
+}