summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-11-22 12:31:46 +0000
committerJeroen Roovers <jer@gentoo.org>2013-11-22 12:31:46 +0000
commit4383a35e22125a8fa2e34cfd79ebd92900e04093 (patch)
treebb13ea25ec3f07549237121b19c52e99ab26c4b0 /x11-misc/xosview
parentversion bump (diff)
downloadgentoo-2-4383a35e22125a8fa2e34cfd79ebd92900e04093.tar.gz
gentoo-2-4383a35e22125a8fa2e34cfd79ebd92900e04093.tar.bz2
gentoo-2-4383a35e22125a8fa2e34cfd79ebd92900e04093.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xosview')
-rw-r--r--x11-misc/xosview/ChangeLog7
-rw-r--r--x11-misc/xosview/xosview-1.16.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/xosview/ChangeLog b/x11-misc/xosview/ChangeLog
index 137d173f9876..7848a5bd9366 100644
--- a/x11-misc/xosview/ChangeLog
+++ b/x11-misc/xosview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xosview
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.76 2013/08/13 14:59:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/ChangeLog,v 1.77 2013/11/22 12:31:46 jer Exp $
+
+*xosview-1.16 (22 Nov 2013)
+
+ 22 Nov 2013; Jeroen Roovers <jer@gentoo.org> +xosview-1.16.ebuild:
+ Version bump.
*xosview-1.15 (13 Aug 2013)
diff --git a/x11-misc/xosview/xosview-1.16.ebuild b/x11-misc/xosview/xosview-1.16.ebuild
new file mode 100644
index 000000000000..f2252ac16a27
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/xosview-1.16.ebuild,v 1.1 2013/11/22 12:31:46 jer Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+src_prepare() {
+ sed -i -e 's:lib/X11/app:share/X11/app:g' -i ${PN}.1 || die
+ sed -i -e "s:Git:${PV}:g" ${PN}.cc || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS=''
+}
+
+src_install() {
+ dobin ${PN}
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+ doman *.1
+ dodoc CHANGES README.linux TODO
+}
+
+pkg_postinst() {
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}