summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-09-17 13:47:00 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-09-17 13:47:00 +0000
commit23500cafc46bebf85205eac51a0ead46a2d46431 (patch)
treeb9037d66f94ce03b23f6950a42a2873004628a8b /x11-misc
parentVersion bump (diff)
downloadgentoo-2-23500cafc46bebf85205eac51a0ead46a2d46431.tar.gz
gentoo-2-23500cafc46bebf85205eac51a0ead46a2d46431.tar.bz2
gentoo-2-23500cafc46bebf85205eac51a0ead46a2d46431.zip
Re-introduce lightdm package. Bug #365311. Thanks to Christoph Junghans <ottxor@gentoo.org>
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/lightdm/ChangeLog11
-rw-r--r--x11-misc/lightdm/files/lightdm-0.9.7-gtk.patch27
-rw-r--r--x11-misc/lightdm/lightdm-0.9.7.ebuild119
-rw-r--r--x11-misc/lightdm/metadata.xml16
4 files changed, 173 insertions, 0 deletions
diff --git a/x11-misc/lightdm/ChangeLog b/x11-misc/lightdm/ChangeLog
new file mode 100644
index 000000000000..fa7124d395fd
--- /dev/null
+++ b/x11-misc/lightdm/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/lightdm
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.8 2011/09/17 13:47:00 hwoarang Exp $
+
+*lightdm-0.9.7 (17 Sep 2011)
+
+ 17 Sep 2011; Markos Chandras <hwoarang@gentoo.org> +lightdm-0.9.7.ebuild,
+ +files/lightdm-0.9.7-gtk.patch, +metadata.xml:
+ Re-introduce lightdm package. Bug #365311. Thanks to Christoph Junghans
+ <ottxor@gentoo.org>
+
diff --git a/x11-misc/lightdm/files/lightdm-0.9.7-gtk.patch b/x11-misc/lightdm/files/lightdm-0.9.7-gtk.patch
new file mode 100644
index 000000000000..c3ab47cc1b9f
--- /dev/null
+++ b/x11-misc/lightdm/files/lightdm-0.9.7-gtk.patch
@@ -0,0 +1,27 @@
+diff -Naur lightdm-0.9.2.orig/configure.ac lightdm-0.9.2/configure.ac
+--- lightdm-0.9.2.orig/configure.ac 2011-07-27 19:56:54.000000000 +0200
++++ lightdm-0.9.2/configure.ac 2011-07-27 20:12:48.000000000 +0200
+@@ -108,10 +108,19 @@
+ fi
+ AM_CONDITIONAL(HAVE_QT_GREETER, test $have_qt = yes)
+
+-PKG_CHECK_MODULES(LIGHTDM_GTK_GREETER, [
+- gtk+-3.0
+- gmodule-export-2.0
+-], have_gtk=yes, have_gtk=no)
++
++AC_ARG_ENABLE(liblightdm-gtk,
++ AS_HELP_STRING([--disable-liblightdm-gtk],[Enable LightDM client gtk libraries [[default=yes]]]),
++ [enable_liblightdm_gtk=$enableval],
++ [enable_liblightdm_gtk="yes"])
++
++have_gtk=no
++if test x"$enable_liblightdm_gtk" = "xyes"; then
++ PKG_CHECK_MODULES(LIGHTDM_GTK_GREETER, [
++ gtk+-3.0 >= 3.0
++ gmodule-export-2.0
++ ], have_gtk=yes, have_gtk=no)
++fi
+ AM_CONDITIONAL(HAVE_GTK_GREETER, test $have_gtk = yes)
+
+ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
diff --git a/x11-misc/lightdm/lightdm-0.9.7.ebuild b/x11-misc/lightdm/lightdm-0.9.7.ebuild
new file mode 100644
index 000000000000..f9bf6d18c35f
--- /dev/null
+++ b/x11-misc/lightdm/lightdm-0.9.7.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-0.9.7.ebuild,v 1.1 2011/09/17 13:47:00 hwoarang Exp $
+
+EAPI=4
+inherit autotools eutils pam
+
+DESCRIPTION="A lightweight display manager"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ gtk? ( http://dev.gentoo.org/~hwoarang/distfiles/${PN}-gentoo-patch.tar.gz )"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="branding +gtk +introspection qt4"
+
+RDEPEND="dev-libs/glib:2
+ virtual/pam
+ x11-libs/libxklavier
+ x11-libs/libX11
+ dev-libs/libxml2
+ gtk? ( x11-libs/gtk+:3
+ x11-themes/gnome-themes-standard
+ x11-themes/gnome-icon-theme )
+ qt4? ( x11-libs/qt-core:4
+ x11-libs/qt-dbus:4 )
+ sys-apps/accountsservice"
+DEPEND="${RDEPEND}
+ dev-lang/vala:0.12
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ introspection? ( dev-libs/gobject-introspection )"
+
+REQUIRED_USE="branding? ( gtk )"
+DOCS=( NEWS )
+
+pkg_setup() {
+ if ! use gtk && ! use qt4; then
+ eerror
+ eerror "You have neither 'gtk' nor 'qt4' useflags enabled."
+ eerror "Please enable at least one of the two available greeter"
+ eerror "options"
+ die "Neither gtk nor qt4 useflag is enabled"
+ fi
+}
+
+src_prepare() {
+ # Make gtk greeter optional
+ epatch "${FILESDIR}/${P}-gtk.patch"
+ # remove GNOME_COMPILE_WARNING reference which requires
+ # gnome-base/gnome-common dependency.
+ sed -i -e "/GNOME_COMPILE_WARNING/d" "${S}"/configure.ac || die
+ # Hide users with uid < 1000
+ sed -i -e "/minimum-uid/s:500:1000:" "${S}"/data/users.conf || die
+ eautoreconf
+}
+
+src_configure() {
+ # Maybe in the future, we can support some automatic session and user
+ # recognition. Until then, use default values
+ local default=gnome greeter= user=root
+
+ # gtk has higher priority because Qt4 interface sucks :)
+ use qt4 && greeter=lightdm-qt-greeter
+ use gtk && greeter=lightdm-gtk-greeter
+
+ # Let user know how lightdm is configured
+ einfo "Gentoo configuration"
+ einfo "Default greeter: ${greeter}"
+ einfo "Default session: ${default}"
+ einfo "Greeter user: ${user}"
+
+ # do the actual configuration
+ econf --localstatedir=/var \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable qt4 liblightdm-qt) \
+ $(use_enable gtk liblightdm-gtk) \
+ --with-user-session=${default} \
+ --with-greeter-session=${greeter} \
+ --with-greeter-user=${user} \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # Install missing files
+ insinto /etc/${PN}/
+ doins "${S}"/data/{users,keys}.conf
+ # remove .la files
+ find "${ED}" -name "*.la" -exec rm -rf {} +
+ rm -Rf "${ED}"/etc/init || die
+
+ if use gtk; then
+ insinto /etc/${PN}/
+ doins "${WORKDIR}"/${PN}-gtk-greeter.conf
+ if use branding; then
+ insinto /usr/share/${PN}/backgrounds/
+ doins "${WORKDIR}"/gentoo1024x768.png
+ sed -i -e "/background/s:=.*:=/usr/share/${PN}/backgrounds/gentoo1024x768.png:" \
+ "${D}"/etc/${PN}/${PN}-gtk-greeter.conf || die
+ fi
+ fi
+ pamd_mimic system-local-login lightdm auth account session
+}
+
+pkg_postinst() {
+ elog
+ elog "Even though the default /etc/${PN}/${PN}.conf will work for"
+ elog "most users, make sure you configure it to suit your needs"
+ elog "before using ${PN} for the first time."
+ elog "You can test the configuration file using the following"
+ elog "command: ${PN} --test-mode -c /etc/${PN}/${PN}.conf. This"
+ elog "requires xorg-server to be built with the 'kdrive' useflag."
+ elog
+}
diff --git a/x11-misc/lightdm/metadata.xml b/x11-misc/lightdm/metadata.xml
new file mode 100644
index 000000000000..a378f0381f15
--- /dev/null
+++ b/x11-misc/lightdm/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+ <flag name="branding">Replace original gnome background with one from Gentoo ten project</flag>
+ <flag name="introspection">Use dev-libs/gobject-introspection for introspection</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+