summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-06-04 18:04:11 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-06-04 18:04:11 +0000
commitddc831f418d76b9a4da3f7ec2d845811da8bc778 (patch)
treed3d148a0fdaa481219862cd52666c054ca31f474 /x11-misc
parentversion bump; remove unneeded nonfatal (bug #551178) (diff)
downloadgentoo-2-ddc831f418d76b9a4da3f7ec2d845811da8bc778.tar.gz
gentoo-2-ddc831f418d76b9a4da3f7ec2d845811da8bc778.tar.bz2
gentoo-2-ddc831f418d76b9a4da3f7ec2d845811da8bc778.zip
Fix bug 551202, plus various other enhancements to the ebuild.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/tinymount/ChangeLog5
-rw-r--r--x11-misc/tinymount/tinymount-0.2.8.ebuild35
2 files changed, 21 insertions, 19 deletions
diff --git a/x11-misc/tinymount/ChangeLog b/x11-misc/tinymount/ChangeLog
index 8c7f78c0e550..779146727ee3 100644
--- a/x11-misc/tinymount/ChangeLog
+++ b/x11-misc/tinymount/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/tinymount
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/ChangeLog,v 1.8 2015/06/04 16:54:48 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/ChangeLog,v 1.9 2015/06/04 18:04:11 pesa Exp $
+
+ 04 Jun 2015; Davide Pesavento <pesa@gentoo.org> tinymount-0.2.8.ebuild:
+ Fix bug 551202, plus various other enhancements to the ebuild.
04 Jun 2015; Davide Pesavento <pesa@gentoo.org> -tinymount-0.2.6-r1.ebuild:
old
diff --git a/x11-misc/tinymount/tinymount-0.2.8.ebuild b/x11-misc/tinymount/tinymount-0.2.8.ebuild
index 2f6859207b11..2f56f626d52c 100644
--- a/x11-misc/tinymount/tinymount-0.2.8.ebuild
+++ b/x11-misc/tinymount/tinymount-0.2.8.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/tinymount-0.2.8.ebuild,v 1.1 2015/02/03 05:54:47 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/tinymount-0.2.8.ebuild,v 1.2 2015/06/04 18:04:11 pesa Exp $
EAPI=5
-unset _live_inherits
PLOCALES="ru uk"
+inherit l10n qt4-r2
-if [[ ${PV} == *9999* ]]; then
- _live_inherits="git-2"
- EGIT_REPO_URI="git://github.com/limansky/${PN}.git"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI=("https://github.com/limansky/${PN}.git")
+ inherit git-r3
else
SRC_URI="https://github.com/limansky/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-inherit l10n qt4-r2 ${_live_inherits}
-
-DESCRIPTION="Simple disk mount utility"
-HOMEPAGE="http://github.com/limansky/tinymount"
+DESCRIPTION="Simple graphical utility for disk mounting"
+HOMEPAGE="https://github.com/limansky/tinymount"
LICENSE="GPL-2"
SLOT="0"
IUSE="debug libnotify"
-COMMON_DEPEND="dev-qt/qtgui:4
+COMMON_DEPEND="
+ dev-qt/qtcore:4
dev-qt/qtdbus:4
+ dev-qt/qtgui:4
libnotify? ( x11-libs/libnotify )"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
@@ -35,24 +35,23 @@ DOCS=( ChangeLog README.md )
src_prepare() {
remove_locale() {
- # this is nonfatal sed, so '|| die' unneeded here
- sed -i -e "/TRANSLATIONS/s/translations\/${PN}_${1}.ts//" src/src.pro
+ sed -i -e "/translations\/${PN}_${1}.ts/d" src/src.pro || die
}
# Check for locales added/removed from previous version
- l10n_find_plocales_changes "src/translations" "${PN}_" '.ts'
+ l10n_find_plocales_changes src/translations "${PN}_" .ts
# Prevent disabled locales from being built
l10n_for_each_disabled_locale_do remove_locale
- # bug #441986
- sed -i src/src.pro -e 's|-Werror||g' || die # bug #441986
+ # Bug 441986
+ sed -i -e 's|-Werror||g' src/src.pro || die
qt4-r2_src_prepare
}
src_configure() {
- local params="PREFIX=/usr"
- use libnotify && params="${params} CONFIG+=with_libnotify"
- eqmake4 ${params}
+ eqmake4 \
+ PREFIX="${EPREFIX}/usr" \
+ $(use libnotify && echo CONFIG+=with_libnotify)
}