summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-24 11:14:30 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-24 11:14:30 +0000
commitbdf28188dbd9e280ba72cee2521a4173bba91526 (patch)
tree6368966643fac23269dca1e04fb4abbafca04809 /x11-plugins/noscript
parentrestore arm/s390/sh keywords #214464 (diff)
downloadgentoo-2-bdf28188dbd9e280ba72cee2521a4173bba91526.tar.gz
gentoo-2-bdf28188dbd9e280ba72cee2521a4173bba91526.tar.bz2
gentoo-2-bdf28188dbd9e280ba72cee2521a4173bba91526.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/noscript')
-rw-r--r--x11-plugins/noscript/ChangeLog7
-rw-r--r--x11-plugins/noscript/noscript-1.5.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-plugins/noscript/ChangeLog b/x11-plugins/noscript/ChangeLog
index 40785f6e12c5..4e909d30cfec 100644
--- a/x11-plugins/noscript/ChangeLog
+++ b/x11-plugins/noscript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/noscript
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.96 2008/03/17 12:25:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.97 2008/03/24 11:14:30 armin76 Exp $
+
+*noscript-1.5.2 (24 Mar 2008)
+
+ 24 Mar 2008; Raúl Porcel <armin76@gentoo.org> +noscript-1.5.2.ebuild:
+ Version bump
*noscript-1.5 (17 Mar 2008)
diff --git a/x11-plugins/noscript/noscript-1.5.2.ebuild b/x11-plugins/noscript/noscript-1.5.2.ebuild
new file mode 100644
index 000000000000..909512dd0b5b
--- /dev/null
+++ b/x11-plugins/noscript/noscript-1.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/noscript-1.5.2.ebuild,v 1.1 2008/03/24 11:14:30 armin76 Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Firefox plugin to disable javascript"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+}