summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-01-07 05:00:37 +0000
committerOlivier Crête <tester@gentoo.org>2008-01-07 05:00:37 +0000
commitd899a645b7c179943fa2e596b17aa1ae8d68468c (patch)
tree852ecc37b318c02a7c35d6e01e071418e15f17fa /x11-plugins/pidgin-latex
parentAdd build-time dep on pkgconfig (diff)
downloadgentoo-2-d899a645b7c179943fa2e596b17aa1ae8d68468c.tar.gz
gentoo-2-d899a645b7c179943fa2e596b17aa1ae8d68468c.tar.bz2
gentoo-2-d899a645b7c179943fa2e596b17aa1ae8d68468c.zip
Add dep on gtk (and check that pidgin has it too)
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins/pidgin-latex')
-rw-r--r--x11-plugins/pidgin-latex/ChangeLog7
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild23
2 files changed, 21 insertions, 9 deletions
diff --git a/x11-plugins/pidgin-latex/ChangeLog b/x11-plugins/pidgin-latex/ChangeLog
index 2de8a363861e..2da41b74ae65 100644
--- a/x11-plugins/pidgin-latex/ChangeLog
+++ b/x11-plugins/pidgin-latex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/pidgin-latex
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.4 2007/08/28 16:19:13 nixnut Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/ChangeLog,v 1.5 2008/01/07 05:00:37 tester Exp $
+
+ 07 Jan 2008; <tester@gentoo.org> pidgin-latex-1.0.ebuild:
+ Add dep on gtk (and check that pidgin has it too)
28 Aug 2007; nixnut <nixnut@gentoo.org> pidgin-latex-1.0.ebuild:
Stable on ppc wrt bug 189781
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild
index 9e1c13514d77..e2e4ccc39fe8 100644
--- a/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild,v 1.5 2007/08/28 16:19:13 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.0.ebuild,v 1.6 2008/01/07 05:00:37 tester Exp $
inherit flag-o-matic multilib
@@ -13,12 +13,21 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="net-im/pidgin"
-RDEPEND="virtual/tetex
- media-gfx/imagemagick"
+DEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2"
+RDEPEND="${DEPEND}
+ virtual/tetex
+ media-gfx/imagemagick"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
+
src_compile()
{
append-flags -fPIC
@@ -27,7 +36,7 @@ src_compile()
src_install()
{
- make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX=${D}/usr \
+ make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX="${D}/usr" \
|| die "make install failed"
- dodoc README CHANGELOG COPYING TODO
+ dodoc README CHANGELOG TODO
}