summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-12 14:39:08 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-12 14:39:08 +0000
commit35b9063d63672e884554e98f73897f29f712e502 (patch)
treecfc6cb32f966e48147634b8ba7377e56c2d5763a /x11-plugins/wmfishtime
parentremove useless mpeg USE-flag, add fontconfig USE-flag and correct freetype co... (diff)
downloadgentoo-2-35b9063d63672e884554e98f73897f29f712e502.tar.gz
gentoo-2-35b9063d63672e884554e98f73897f29f712e502.tar.bz2
gentoo-2-35b9063d63672e884554e98f73897f29f712e502.zip
Ported to GTK+-2.0.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmfishtime')
-rw-r--r--x11-plugins/wmfishtime/ChangeLog10
-rw-r--r--x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r13
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch60
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild35
4 files changed, 106 insertions, 2 deletions
diff --git a/x11-plugins/wmfishtime/ChangeLog b/x11-plugins/wmfishtime/ChangeLog
index 08e8c8488d10..886a80d775e4 100644
--- a/x11-plugins/wmfishtime/ChangeLog
+++ b/x11-plugins/wmfishtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmfishtime
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/ChangeLog,v 1.15 2007/02/21 23:33:05 jokey Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/ChangeLog,v 1.16 2008/01/12 14:39:07 drac Exp $
+
+*wmfishtime-1.24-r1 (12 Jan 2008)
+
+ 12 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/wmfishtime-1.24-gtk.patch, +wmfishtime-1.24-r1.ebuild:
+ Ported to GTK+-2.0.
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r1 b/x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r1
new file mode 100644
index 000000000000..781cad5bd388
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r1
@@ -0,0 +1,3 @@
+MD5 8723b7c6a58b8c41a1dd5973ede4b296 wmfishtime-1.24.tar.gz 21895
+RMD160 9c705351ecbc28e15fd8e3b73712940fdb73baf1 wmfishtime-1.24.tar.gz 21895
+SHA256 7d92889d295558acd8af79f4d74c6fa7c980ac1010b7f0691249a117b34bba07 wmfishtime-1.24.tar.gz 21895
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
new file mode 100644
index 000000000000..a2c8342938f5
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
@@ -0,0 +1,60 @@
+diff -ur wmfishtime-1.24.orig/fishmon.c wmfishtime-1.24/fishmon.c
+--- wmfishtime-1.24.orig/fishmon.c 2004-05-13 02:55:59.000000000 +0300
++++ wmfishtime-1.24/fishmon.c 2008-01-12 16:19:34.000000000 +0200
+@@ -648,6 +648,7 @@
+
+ /* make a copy for the iconwin - parameters are the same */
+ memcpy(&attri, &attr, sizeof(GdkWindowAttr));
++ attri.window_type = GDK_WINDOW_CHILD;
+
+ sizehints.flags = USSize;
+ sizehints.width = 64;
+@@ -679,7 +680,6 @@
+ wmhints.window_group = win;
+ wmhints.flags =
+ StateHint | IconWindowHint | IconPositionHint | WindowGroupHint;
+- XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+
+ bm.gc = gdk_gc_new(bm.win);
+
+@@ -693,6 +693,8 @@
+
+ gdk_window_show(bm.win);
+
++ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++
+ #undef MASK
+ } /* make_new_fishmon_dockapp */
+
+diff -ur wmfishtime-1.24.orig/Makefile wmfishtime-1.24/Makefile
+--- wmfishtime-1.24.orig/Makefile 2001-05-26 23:49:41.000000000 +0300
++++ wmfishtime-1.24/Makefile 2008-01-12 16:22:30.000000000 +0200
+@@ -2,11 +2,11 @@
+ DESTDIR =
+
+ # where to install this program
+-PREFIX = $(DESTDIR)/usr/X11R6
++PREFIX = $(DESTDIR)/usr
+
+ # no user serviceable parts below this line
+ # optimization cflags
+-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
++CFLAGS += -Wall `pkg-config gtk+-2.0 --cflags` ${EXTRA}
+ # profiling cflags
+ # CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
+ # test coverage cflags
+@@ -16,7 +16,7 @@
+ CC = gcc
+ SHELL = sh
+ OBJS = fishmon.o
+-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
++LIBS = `pkg-config gtk+-2.0 --libs`
+ INSTALL = -m 755
+
+ all: wmfishtime
+@@ -30,4 +30,4 @@
+ # You're going to have to be root to do this!
+ install:
+ install $(INSTALL) wmfishtime $(PREFIX)/bin
+- install $(INSTALL) wmfishtime.1 $(PREFIX)/man/man1
++ install $(INSTALL) wmfishtime.1 $(PREFIX)/share/man/man1
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
new file mode 100644
index 000000000000..c696fc517251
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild,v 1.1 2008/01/12 14:39:07 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}