summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-12-05 10:53:57 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-12-05 10:53:57 +0000
commit1eea729f21af8d8ff703e9c456a82c2d90b20ab8 (patch)
tree4d1e385adca119f4588808423354a421afb955a0 /x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
parentversion bump; mark1.2.5 stable (Manifest recommit) (diff)
downloadgentoo-2-1eea729f21af8d8ff703e9c456a82c2d90b20ab8.tar.gz
gentoo-2-1eea729f21af8d8ff703e9c456a82c2d90b20ab8.tar.bz2
gentoo-2-1eea729f21af8d8ff703e9c456a82c2d90b20ab8.zip
Revision bump containing fix for newer versions of media-gfx/imagemagick. Closes #71894
Diffstat (limited to 'x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild')
-rw-r--r--x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
new file mode 100644
index 000000000000..1e230fdcfc00
--- /dev/null
+++ b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild,v 1.1 2004/12/05 10:53:57 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P=${PN/grabi/GrabI}
+S=${WORKDIR}/${MY_P}-${PV}/${MY_P}
+
+DESCRIPTION="wmGrabImage grabs an image from the WWW and displays it"
+SRC_URI="http://www.dockapps.com/download.php/id/19/${MY_P}-${PV}.tgz"
+HOMEPAGE="http://www.dockapps.com/file.php/id/12"
+
+DEPEND="virtual/x11
+ >=net-misc/wget-1.9-r2
+ >=media-gfx/imagemagick-5.5.7.15
+ >=sys-apps/sed-4"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-noman.patch
+}
+
+src_compile()
+{
+ sed -i -e 's/-geom /-geometry /' GrabImage
+ emake clean || die "clean failed"
+ emake CFLAGS="${CFLAGS} -Wall" || die "make failed"
+}
+
+src_install()
+{
+ cd ${S}
+ dodir /usr/bin
+ einstall DESTDIR="${D}/usr" || die "make install failed"
+
+ doman wmGrabImage.1
+
+ cd ..
+ dodoc BUGS CHANGES HINTS TODO
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}