summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-01-19 16:21:08 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-01-19 16:21:08 +0000
commitbd791233f7b84e21631bb5a9aeb64f4727f9eb47 (patch)
tree63594520674c8478bc5970c8c62d071e2a5294d3 /x11-plugins/wsoundserver
parentVersion bump. Drop the epatch/eautoreconf/elibtoolize as the Flameeyes-magic ... (diff)
downloadgentoo-2-bd791233f7b84e21631bb5a9aeb64f4727f9eb47.tar.gz
gentoo-2-bd791233f7b84e21631bb5a9aeb64f4727f9eb47.tar.bz2
gentoo-2-bd791233f7b84e21631bb5a9aeb64f4727f9eb47.zip
Added patch to fix compilation with --as-needed. Closes bug #248652.
Some ebuild QA fixing. (Portage version: 2.1.6.4/cvs/Linux 2.6.24-tuxonice-r9 i686)
Diffstat (limited to 'x11-plugins/wsoundserver')
-rw-r--r--x11-plugins/wsoundserver/ChangeLog7
-rw-r--r--x11-plugins/wsoundserver/files/wsoundserver-0.4.1-as-needed.patch22
-rw-r--r--x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild20
3 files changed, 43 insertions, 6 deletions
diff --git a/x11-plugins/wsoundserver/ChangeLog b/x11-plugins/wsoundserver/ChangeLog
index d2ee3df0f414..0e14358a04c0 100644
--- a/x11-plugins/wsoundserver/ChangeLog
+++ b/x11-plugins/wsoundserver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wsoundserver
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wsoundserver/ChangeLog,v 1.5 2007/02/06 02:06:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wsoundserver/ChangeLog,v 1.6 2009/01/19 16:21:08 s4t4n Exp $
+
+ 19 Jan 2009; Michele Noberasco <s4t4n@gentoo.org>
+ wsoundserver-0.4.1.ebuild, +files/wsoundserver-0.4.1-as-needed.patch:
+ Added patch to fix compilation with --as-needed. Closes bug #248652.
+ Some ebuild QA fixing.
06 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-plugins/wsoundserver/files/wsoundserver-0.4.1-as-needed.patch b/x11-plugins/wsoundserver/files/wsoundserver-0.4.1-as-needed.patch
new file mode 100644
index 000000000000..7439b3211b28
--- /dev/null
+++ b/x11-plugins/wsoundserver/files/wsoundserver-0.4.1-as-needed.patch
@@ -0,0 +1,22 @@
+--- configure.in 2009-01-19 16:58:55.000000000 +0100
++++ configure.in.new 2009-01-19 16:58:44.000000000 +0100
+@@ -212,6 +212,7 @@
+ AC_DEFINE(DRIVER_ESD)
+ driver="DRIVER_ESD"
+ else
++ AM_CONDITIONAL(HAVE_ESD,test "x$enable_esd" = xyes)
+ echo "---------------------------------------------------------------------"
+ echo "--- Checking to see which audio header files your system uses.";
+ echo "--- Most of these checks should fail. Do not be alarmed.";
+
+--- wslib/Makefile.am 2009-01-19 17:07:10.000000000 +0100
++++ wslib/Makefile.am.new 2009-01-19 17:07:28.000000000 +0100
+@@ -40,7 +40,7 @@
+ LIBLIST = libwsound.la libwsoundeffect.la -L../wseffectlib/ @LIBRARY_SEARCH_PATH@ @XLIBS@
+
+
+-libwsound_la_LIBADD =
++libwsound_la_LIBADD = @XLIBS@
+
+ CLEANFILES =
+
diff --git a/x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild b/x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild
index db9206f7e469..99d5bdc9e749 100644
--- a/x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild
+++ b/x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild,v 1.5 2007/07/11 20:39:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wsoundserver/wsoundserver-0.4.1.ebuild,v 1.6 2009/01/19 16:21:08 s4t4n Exp $
+
+inherit autotools eutils
MY_P="${P/wsoundserver/WSoundServer}-new"
S="${WORKDIR}/${MY_P}"
@@ -23,24 +25,32 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~ppc x86"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ eautoreconf
+}
+
src_compile() {
local myconf="--prefix=/usr --with-x --sysconfdir=/etc/X11"
myconf="${myconf} `use_enable esd`"
- cd ${S}
+ cd "${S}"
emake clean >/dev/null 2>&1
econf || die "configure failed"
emake || die "make failed"
}
src_install() {
- cd ${S}
einstall sysconfdir=/etc/X11 || die "make install failed"
dodoc AUTHORS ChangeLog README
insinto /usr/share/WindowMaker/Pixmaps
- doins ${FILESDIR}/WSoundServer.xpm
+ doins "${FILESDIR}/WSoundServer.xpm"
}
pkg_postinst() {