summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-04-10 19:08:25 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-04-10 19:08:25 +0000
commit1fe2708c836295b0ae6e103a12646322c439ba41 (patch)
tree5b725de18a9f836d4dbb38198b4fe572e9982e7a /x11-plugins
parentMake dependencies compatible with split Qt:4, fixing bug #217186. (diff)
downloadgentoo-2-1fe2708c836295b0ae6e103a12646322c439ba41.tar.gz
gentoo-2-1fe2708c836295b0ae6e103a12646322c439ba41.tar.bz2
gentoo-2-1fe2708c836295b0ae6e103a12646322c439ba41.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/noscript/ChangeLog5
-rw-r--r--x11-plugins/noscript/noscript-1.5.8.ebuild38
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-plugins/noscript/ChangeLog b/x11-plugins/noscript/ChangeLog
index c047441e7a64..ab8abed86e6b 100644
--- a/x11-plugins/noscript/ChangeLog
+++ b/x11-plugins/noscript/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/noscript
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.100 2008/04/09 11:35:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.101 2008/04/10 19:08:25 armin76 Exp $
+
+ 10 Apr 2008; Raúl Porcel <armin76@gentoo.org> +noscript-1.5.8.ebuild:
+ Version bump
09 Apr 2008; Raúl Porcel <armin76@gentoo.org> -noscript-1.5.8.ebuild:
1.5.8 SRC_URI gives 404, remove
diff --git a/x11-plugins/noscript/noscript-1.5.8.ebuild b/x11-plugins/noscript/noscript-1.5.8.ebuild
new file mode 100644
index 000000000000..e68198018d2c
--- /dev/null
+++ b/x11-plugins/noscript/noscript-1.5.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/noscript-1.5.8.ebuild,v 1.3 2008/04/10 19:08:25 armin76 Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Firefox plugin to disable javascript"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+}