summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-01-26 18:21:31 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-01-26 18:21:31 +0000
commit4923f19d9de8e8231e4340bb0fbd9cb1bcf81ac5 (patch)
treefd21f4ed498eb60a0c4ca742f230947c7f32f973 /x11-plugins
parentfixes SRC_URI/DESCRIPTION (diff)
downloadgentoo-2-4923f19d9de8e8231e4340bb0fbd9cb1bcf81ac5.tar.gz
gentoo-2-4923f19d9de8e8231e4340bb0fbd9cb1bcf81ac5.tar.bz2
gentoo-2-4923f19d9de8e8231e4340bb0fbd9cb1bcf81ac5.zip
Revision bump, with patch that makes parsing from header faster in maildir format.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmail/ChangeLog8
-rw-r--r--x11-plugins/wmail/files/digest-wmail-2.0-r33
-rw-r--r--x11-plugins/wmail/files/wmail-2.0.maildir-parse-from.patch12
-rw-r--r--x11-plugins/wmail/wmail-2.0-r3.ebuild40
4 files changed, 62 insertions, 1 deletions
diff --git a/x11-plugins/wmail/ChangeLog b/x11-plugins/wmail/ChangeLog
index 23ad03c6cc8e..2909b6a768dc 100644
--- a/x11-plugins/wmail/ChangeLog
+++ b/x11-plugins/wmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmail
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/ChangeLog,v 1.14 2006/05/18 01:07:26 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/ChangeLog,v 1.15 2007/01/26 18:21:31 s4t4n Exp $
+
+*wmail-2.0-r3 (26 Jan 2007)
+
+ 26 Jan 2007; Michele Noberasco <s4t4n@gentoo.org> wmail-2.0-r3.ebuild:
+ Revision bump, with patch to make from header parsing faster in maildir format,
+ thanks to Stanislav Kuchar.
18 May 2006; Jason Wever <weeve@gentoo.org> wmail-2.0-r2.ebuild:
Stable on SPARC.
diff --git a/x11-plugins/wmail/files/digest-wmail-2.0-r3 b/x11-plugins/wmail/files/digest-wmail-2.0-r3
new file mode 100644
index 000000000000..4b15c699901c
--- /dev/null
+++ b/x11-plugins/wmail/files/digest-wmail-2.0-r3
@@ -0,0 +1,3 @@
+MD5 a4eb33712e0650e79ffdffce2c9a1e4c wmail-2.0.tar.gz 46468
+RMD160 5901792368a309734c80333dd14dcee427151d8d wmail-2.0.tar.gz 46468
+SHA256 edcf77bf6a638b96dbd78efe4802d260a68385ab2deb6d6774e325ea0cd3d245 wmail-2.0.tar.gz 46468
diff --git a/x11-plugins/wmail/files/wmail-2.0.maildir-parse-from.patch b/x11-plugins/wmail/files/wmail-2.0.maildir-parse-from.patch
new file mode 100644
index 000000000000..c39329286a57
--- /dev/null
+++ b/x11-plugins/wmail/files/wmail-2.0.maildir-parse-from.patch
@@ -0,0 +1,12 @@
+--- src/wmail.c 2007-01-26 19:17:08.000000000 +0100
++++ src/wmail.c.new 2007-01-26 19:17:02.000000000 +0100
+@@ -871,6 +871,9 @@
+ InsertName( ParseFromField( buf+6 ), checksum,
+ isNewMail ? FLAG_INITIAL : FLAG_READ );
+
++ // got name, address: do not parse the rest of email
++ break;
++
+ //++numMails;
+ }
+ }
diff --git a/x11-plugins/wmail/wmail-2.0-r3.ebuild b/x11-plugins/wmail/wmail-2.0-r3.ebuild
new file mode 100644
index 000000000000..d1caf56452ce
--- /dev/null
+++ b/x11-plugins/wmail/wmail-2.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmail/wmail-2.0-r3.ebuild,v 1.1 2007/01/26 18:21:31 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Window Maker dock application showing incoming mail"
+SRC_URI="http://www.minet.uni-jena.de/~topical/sveng/wmail/${P}.tar.gz"
+HOMEPAGE="http://www.dockapps.org/file.php/id/70"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="x11-libs/libdockapp"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.support-libdockapp-0.5.0.patch
+
+ # make from parsing in maildir format faster, thanks
+ # to Stanislav Kuchar
+ epatch ${FILESDIR}/${P}.maildir-parse-from.patch
+}
+
+src_compile()
+{
+ econf --enable-delt-xpms || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ dobin src/wmail
+ dodoc README wmailrc-sample
+}