summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-01 15:13:01 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-01 15:13:01 +0000
commit675bb0f8c5398d56a9931d1df34587a568156d0c (patch)
tree565e649605170a53497bbed3501c7f58a0ff1ff2 /x11-plugins
parentpunt (diff)
downloadgentoo-2-675bb0f8c5398d56a9931d1df34587a568156d0c.tar.gz
gentoo-2-675bb0f8c5398d56a9931d1df34587a568156d0c.tar.bz2
gentoo-2-675bb0f8c5398d56a9931d1df34587a568156d0c.zip
Version bump, plus support for crosscompile, LDFLAGS, etc. Closes bug #207916. Wiped out older version.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmacpi/ChangeLog11
-rw-r--r--x11-plugins/wmacpi/files/wmacpi-2.2_rc1-makefile.patch71
-rw-r--r--x11-plugins/wmacpi/wmacpi-1.99_p7.ebuild34
-rw-r--r--x11-plugins/wmacpi/wmacpi-2.2_rc1.ebuild43
4 files changed, 123 insertions, 36 deletions
diff --git a/x11-plugins/wmacpi/ChangeLog b/x11-plugins/wmacpi/ChangeLog
index 673519e8be15..e22967d8cd09 100644
--- a/x11-plugins/wmacpi/ChangeLog
+++ b/x11-plugins/wmacpi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/wmacpi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpi/ChangeLog,v 1.21 2007/03/04 20:13:48 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpi/ChangeLog,v 1.22 2008/02/01 15:13:01 s4t4n Exp $
+
+*wmacpi-2.2_rc1 (01 Feb 2008)
+
+ 01 Feb 2008; Michele Noberasco <s4t4n@gentoo.org> wmacpi-2.2_rc1.ebuild:
+ Version bump, plus fixes for crosscompile, LDFLAGS, etc. Closes bug #207916.
+ wmacpi-1.99_p7.ebuild:
+ Wiped out older version.
04 Mar 2007; Piotr Jaroszyński <peper@gentoo.org> wmacpi-1.99_p7.ebuild,
wmacpi-2.1_rc1.ebuild:
diff --git a/x11-plugins/wmacpi/files/wmacpi-2.2_rc1-makefile.patch b/x11-plugins/wmacpi/files/wmacpi-2.2_rc1-makefile.patch
new file mode 100644
index 000000000000..af142fd574ee
--- /dev/null
+++ b/x11-plugins/wmacpi/files/wmacpi-2.2_rc1-makefile.patch
@@ -0,0 +1,71 @@
+--- Makefile.orig 2007-07-13 17:26:30.000000000 +0200
++++ Makefile 2008-01-28 16:36:41.000000000 +0100
+@@ -13,8 +13,8 @@
+ #OPT = -pg -g
+
+ CC := gcc
+-CFLAGS := $(OPT) -Wall -W -g -ansi -I/usr/X11R6/include
+-LDFLAGS := $(OPT) -lX11 -ldockapp
++CFLAGS := $(OPT) -Wall -W -g -ansi -I/usr/include
++LDFLAGS += -lX11 -ldockapp
+
+ WMSRC := wmacpi.c libacpi.c
+ HEADERS := libacpi.h wmacpi.h
+@@ -22,11 +22,12 @@
+ doc_targets := wmacpi.1
+
+ ifdef BUILD_CLI
+-targets += acpi
+-doc_targets += acpi.1
++targets += acpi-batt-status
++doc_targets += acpi-batt-status.1
+ endif
+
+-PREFIX := /usr/local
++PREFIX := /usr
++MANDIR := $(PREFIX)/share/man
+
+ all: $(targets)
+
+@@ -34,20 +35,20 @@
+ WMOBJ := $(patsubst %.c,%.o,$(filter %.c,$(WMSRC)))
+
+ # include per-file dependencies
+--include $(WMOBJ:.o=.d)
++#-include $(WMOBJ:.o=.d)
+
+ wmacpi: $(WMOBJ)
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ # for the Debian package, we want to make building the command line tools
+ # optional. So, we hide all the necessary stuff here . . .
+ ifdef BUILD_CLI
+-CLSRC := acpi.c libacpi.c
++CLSRC := acpi-batt-status.c libacpi.c
+ CLOBJ := $(patsubst %.c,%.o,$(filter %.c,$(CLSRC)))
+--include $(CLOBJ:.o=.d)
++#-include $(CLOBJ:.o=.d)
+
+-acpi: $(CLOBJ)
+- $(CC) $(LDFLAGS) -o $@ $^
++acpi-batt-status: $(CLOBJ)
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+ endif
+
+ # build per-file dependencies - note that -MM may not be supported
+@@ -62,10 +63,10 @@
+ rm -f *.d $(targets)
+
+ install: $(targets)
+- install -d $(PREFIX)/bin/
+- install -pc $(targets) $(PREFIX)/bin/
+- install -d $(PREFIX)/man/man1/
+- install -pc $(doc_targets) $(PREFIX)/man/man1/
++ install -d $(DESTDIR)$(PREFIX)/bin/
++ install -pc $(targets) $(DESTDIR)$(PREFIX)/bin/
++ install -d $(DESTDIR)$(MANDIR)/man1/
++ install -p -m 0644 $(doc_targets) $(DESTDIR)$(MANDIR)/man1/
+
+ tags:
+ etags $(WMSRC) $(CLSRC) $(HEADERS)
diff --git a/x11-plugins/wmacpi/wmacpi-1.99_p7.ebuild b/x11-plugins/wmacpi/wmacpi-1.99_p7.ebuild
deleted file mode 100644
index 0ff225bb2115..000000000000
--- a/x11-plugins/wmacpi/wmacpi-1.99_p7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpi/wmacpi-1.99_p7.ebuild,v 1.7 2007/03/04 20:13:48 peper Exp $
-
-IUSE=""
-DESCRIPTION="WMaker DockApp: ACPI status monitor for laptops"
-HOMEPAGE="http://himi.org/wmacpi-ng/"
-MY_PV="1.99r7"
-MY_P="${PN}-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
-SRC_URI="http://himi.org/wmacpi-ng/download/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -sparc amd64 -ppc"
-
-DEPEND="x11-libs/libdockapp"
-
-src_compile()
-{
- emake OPT="${CFLAGS}" || die
-}
-
-src_install()
-{
- # Fix for #60685:
- # acpi and acpi.1 conflict with package sys-power/acpi
- mv acpi acpi-batt-status
- mv acpi.1 acpi-batt-status.1
-
- dobin wmacpi acpi-batt-status
- doman wmacpi.1 acpi-batt-status.1
- dodoc AUTHORS ChangeLog README
-}
diff --git a/x11-plugins/wmacpi/wmacpi-2.2_rc1.ebuild b/x11-plugins/wmacpi/wmacpi-2.2_rc1.ebuild
new file mode 100644
index 000000000000..d0e0ba4ec922
--- /dev/null
+++ b/x11-plugins/wmacpi/wmacpi-2.2_rc1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpi/wmacpi-2.2_rc1.ebuild,v 1.1 2008/02/01 15:13:01 s4t4n Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="WMaker DockApp: ACPI status monitor for laptops"
+HOMEPAGE="http://himi.org/wmacpi/"
+MY_PV="${PV/_}"
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://himi.org/wmacpi/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc -sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libdockapp
+ x11-libs/libX11"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # acpi and acpi.1 conflict with sys-power/acpi - Bug #60685
+ mv acpi.c acpi-batt-status.c
+ mv acpi.1 acpi-batt-status.1
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}" || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_postinst() {
+ elog "The command-line utility are corresponding manpage are installed"
+ elog "as acpi-batt-status to prevent collisions with sys-power/acpi"
+}