summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-02-08 12:00:41 +0000
committerSimon Stelling <blubb@gentoo.org>2005-02-08 12:00:41 +0000
commit88741d98acabf54ea98ced539ea7758ed037e144 (patch)
tree8ce461ec2713d7c56a955af8f9f3c4103c4f74ad /x11-plugins
parentFilter -Os; bug #74708. (diff)
downloadgentoo-2-88741d98acabf54ea98ced539ea7758ed037e144.tar.gz
gentoo-2-88741d98acabf54ea98ced539ea7758ed037e144.tar.bz2
gentoo-2-88741d98acabf54ea98ced539ea7758ed037e144.zip
80405
(Portage version: 2.0.51-r15)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaim-otr/ChangeLog6
-rw-r--r--x11-plugins/gaim-otr/files/gaim-otr-1.0.3-fPIC.patch11
-rw-r--r--x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild10
3 files changed, 25 insertions, 2 deletions
diff --git a/x11-plugins/gaim-otr/ChangeLog b/x11-plugins/gaim-otr/ChangeLog
index b8117ad9e1e7..19a0df057d7a 100644
--- a/x11-plugins/gaim-otr/ChangeLog
+++ b/x11-plugins/gaim-otr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gaim-otr
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/ChangeLog,v 1.4 2005/01/21 14:49:59 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/ChangeLog,v 1.5 2005/02/08 12:00:41 blubb Exp $
+
+ 08 Feb 2005; Simon Stelling <blubb@gentoo.org>
+ +files/gaim-otr-1.0.3-fPIC.patch, gaim-otr-1.0.3.ebuild:
+ added David Leverton's patch to fix bug #80405
*gaim-otr-1.0.3 (21 Jan 2005)
diff --git a/x11-plugins/gaim-otr/files/gaim-otr-1.0.3-fPIC.patch b/x11-plugins/gaim-otr/files/gaim-otr-1.0.3-fPIC.patch
new file mode 100644
index 000000000000..6f00b02e0ae4
--- /dev/null
+++ b/x11-plugins/gaim-otr/files/gaim-otr-1.0.3-fPIC.patch
@@ -0,0 +1,11 @@
+--- gaim-otr-1.0.3/Makefile~ 2005-01-18 18:03:58.000000000 +0000
++++ gaim-otr-1.0.3/Makefile 2005-02-07 22:35:51.173494112 +0000
+@@ -39,7 +39,7 @@
+
+ all: $(TARGET)
+
+-$(TARGET): otr-plugin.o ui.o dialogs.o $(LIBOTRLIBDIR)/libotr.a
++$(TARGET): otr-plugin.o ui.o dialogs.o $(LIBOTRLIBDIR)/libotr.so
+ $(CC) -g -shared $(LDFLAGS) $^ -o $@ $(LDLIBS)
+
+ install: all
diff --git a/x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild b/x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild
index 725962249f28..e4560b1dc05a 100644
--- a/x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild
+++ b/x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild,v 1.1 2005/01/21 14:49:59 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/gaim-otr-1.0.3.ebuild,v 1.2 2005/02/08 12:00:41 blubb Exp $
inherit flag-o-matic eutils debug
@@ -16,6 +16,14 @@ IUSE=""
DEPEND="net-libs/libotr
>=net-im/gaim-1.1.0"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #fix bug #80405
+ epatch ${FILESDIR}/gaim-otr-1.0.3-fPIC.patch
+}
+
src_compile() {
strip-flags
replace-flags -O? -O2