summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-10-10 19:11:01 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-10-10 19:11:01 +0000
commitbb8ff70e3e404ad38eb89733e977e0df4a26773c (patch)
tree39b114af74168ea78ffa3cb5853d07518b89331e /x11-plugins
parentModular X fixes, bug 147238. (diff)
downloadgentoo-2-bb8ff70e3e404ad38eb89733e977e0df4a26773c.tar.gz
gentoo-2-bb8ff70e3e404ad38eb89733e977e0df4a26773c.tar.bz2
gentoo-2-bb8ff70e3e404ad38eb89733e977e0df4a26773c.zip
Modular X fixes, bug 147239.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/astime/ChangeLog10
-rw-r--r--x11-plugins/astime/astime-2.8-r1.ebuild40
-rw-r--r--x11-plugins/astime/files/astime-2.8-gentoo.patch35
-rw-r--r--x11-plugins/astime/files/digest-astime-2.82
-rw-r--r--x11-plugins/astime/files/digest-astime-2.8-r13
5 files changed, 88 insertions, 2 deletions
diff --git a/x11-plugins/astime/ChangeLog b/x11-plugins/astime/ChangeLog
index d668f3a78655..a10a75751d5b 100644
--- a/x11-plugins/astime/ChangeLog
+++ b/x11-plugins/astime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/astime
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/astime/ChangeLog,v 1.7 2006/01/02 10:46:47 s4t4n Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/astime/ChangeLog,v 1.8 2006/10/10 19:11:01 kloeri Exp $
+
+*astime-2.8-r1 (10 Oct 2006)
+
+ 10 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +files/astime-2.8-gentoo.patch, +astime-2.8-r1.ebuild:
+ Modular X fixes, bug 147239.
02 Jan 2006; Michele Noberasco <s4t4n@gentoo.org> astime-2.8.ebuild:
Removed LICENSE and INSTALL from dodoc.
diff --git a/x11-plugins/astime/astime-2.8-r1.ebuild b/x11-plugins/astime/astime-2.8-r1.ebuild
new file mode 100644
index 000000000000..fd556a834ce3
--- /dev/null
+++ b/x11-plugins/astime/astime-2.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/astime/astime-2.8-r1.ebuild,v 1.1 2006/10/10 19:11:01 kloeri Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Analogue clock utility for X Windows."
+HOMEPAGE="http://www.tigr.net/"
+SRC_URI="http://www.tigr.net/afterstep/download/astime/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jpeg"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README
+}
diff --git a/x11-plugins/astime/files/astime-2.8-gentoo.patch b/x11-plugins/astime/files/astime-2.8-gentoo.patch
new file mode 100644
index 000000000000..52dba297ec87
--- /dev/null
+++ b/x11-plugins/astime/files/astime-2.8-gentoo.patch
@@ -0,0 +1,35 @@
+--- autoconf/Makefile.common.in.orig 1999-05-02 17:12:39.000000000 +0200
++++ autoconf/Makefile.common.in 2006-09-12 00:26:40.000000000 +0200
+@@ -9,11 +9,10 @@
+ install: install.bin install.man
+
+ install.bin: $(PROG)
+- $(STRIP) $(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(AFTER_BIN_DIR)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(AFTER_BIN_DIR)
+
+ install.man:
+- $(INSTALL_DATA) $(PROG).man $(AFTER_MAN_DIR)/$(PROG).1x
++ $(INSTALL_DATA) $(PROG).man $(DESTDIR)$(AFTER_MAN_DIR)/$(PROG).1x
+
+ uninstall:
+ $(RMF) $(AFTER_BIN_DIR)/$(PROG)
+--- autoconf/Makefile.defines.in.orig 1999-05-02 17:12:39.000000000 +0200
++++ autoconf/Makefile.defines.in 2006-09-12 00:26:58.000000000 +0200
+@@ -2,6 +2,7 @@
+ # Copyright (c) 1998, Guylhem AZNAR <guylhem@oeil.qc.ca>
+ #
+
++DESTDIR =
+ CC = @CC@
+ CCFLAGS = @CFLAGS@
+ # -march=pentiumpro -mcpu=pentiumpro
+@@ -21,7 +22,7 @@
+ LEXFLAGS =
+
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL@ -s -m 755
++INSTALL_PROGRAM = @INSTALL@ -m 755
+ INSTALL_DATA = @INSTALL@ -m 644
+
+ INCS_X = @X_CFLAGS@
diff --git a/x11-plugins/astime/files/digest-astime-2.8 b/x11-plugins/astime/files/digest-astime-2.8
index 1aa8e9e54e3b..ee87c010a8a6 100644
--- a/x11-plugins/astime/files/digest-astime-2.8
+++ b/x11-plugins/astime/files/digest-astime-2.8
@@ -1 +1,3 @@
MD5 0dd21aa79b93b43840649814f2a40fa0 astime-2.8.tar.gz 49679
+RMD160 a8ce6ae59668e495e4c9126c516d51e56ef733c3 astime-2.8.tar.gz 49679
+SHA256 e3c4328368ea95b85d67b05cd87355ccbc5066fae1ac07f683690cd7b91c9167 astime-2.8.tar.gz 49679
diff --git a/x11-plugins/astime/files/digest-astime-2.8-r1 b/x11-plugins/astime/files/digest-astime-2.8-r1
new file mode 100644
index 000000000000..ee87c010a8a6
--- /dev/null
+++ b/x11-plugins/astime/files/digest-astime-2.8-r1
@@ -0,0 +1,3 @@
+MD5 0dd21aa79b93b43840649814f2a40fa0 astime-2.8.tar.gz 49679
+RMD160 a8ce6ae59668e495e4c9126c516d51e56ef733c3 astime-2.8.tar.gz 49679
+SHA256 e3c4328368ea95b85d67b05cd87355ccbc5066fae1ac07f683690cd7b91c9167 astime-2.8.tar.gz 49679