summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-07-02 06:42:04 +0000
committerMamoru Komachi <usata@gentoo.org>2005-07-02 06:42:04 +0000
commit363a5363ae0bb7a9d97cf7459fbce37b92b82b72 (patch)
tree7ab53560da007895e855a760ba29b0dd82d2947c /x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
parentMake cache directory not world-writable with regard to bug 96296. (diff)
downloadgentoo-2-363a5363ae0bb7a9d97cf7459fbce37b92b82b72.tar.gz
gentoo-2-363a5363ae0bb7a9d97cf7459fbce37b92b82b72.tar.bz2
gentoo-2-363a5363ae0bb7a9d97cf7459fbce37b92b82b72.zip
Added line-scroll patch; bug #97408. Thanks to James Kyte <james.kyte@gmail.com>.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-terms/rxvt/rxvt-2.7.10-r3.ebuild')
-rw-r--r--x11-terms/rxvt/rxvt-2.7.10-r3.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild b/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
new file mode 100644
index 000000000000..f2b4ff2dc73f
--- /dev/null
+++ b/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild,v 1.1 2005/07/02 06:42:04 usata Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="rxvt -- nice small x11 terminal"
+HOMEPAGE="http://www.rxvt.org/
+ http://www.giga.it.okayama-u.ac.jp/~ishihara/opensource/"
+SRC_URI="mirror://sourceforge/rxvt/${P}.tar.gz
+ http://www.giga.it.okayama-u.ac.jp/~ishihara/opensource/${P}-xim-fix.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~mips ~amd64 ~ppc64"
+IUSE="motif cjk xgetdefault linuxkeys"
+
+DEPEND="virtual/libc
+ virtual/x11
+ motif? ( x11-libs/openmotif )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-line-scroll.patch
+ use motif && epatch ${FILESDIR}/${P}-azz4.diff
+ use cjk && epatch ${DISTDIR}/${P}-xim-fix.patch.gz
+ use linguas_ja && epatch ${FILESDIR}/${P}-rk.patch
+
+ uclibctoolize
+}
+
+src_compile() {
+
+ local term
+ if [ -n "${RXVT_TERM}" ] ; then
+ term="${RXVT_TERM}"
+ else
+ term="rxvt"
+ fi
+
+ # bug #22325
+ use linuxkeys && append-flags -DLINUX_KEYS
+ append-ldflags -Wl,-z,now
+
+ econf \
+ --enable-everything \
+ --enable-rxvt-scroll \
+ --enable-next-scroll \
+ --enable-xterm-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-256-color \
+ --enable-menubar \
+ --enable-languages \
+ --enable-xim \
+ --enable-shared \
+ --enable-keepscrolling \
+ --with-term=${term} \
+ $(use_enable xgetdefault) || die
+
+ emake || die
+}
+
+src_install() {
+
+ einstall mandir=${D}/usr/share/man/man1 || die
+
+ cd ${S}/doc
+ dodoc README* *.txt BUGS FAQ
+ dohtml *.html
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "If you want to change default TERM variable other than rxvt,"
+ einfo "set RXVT_TERM environment variable and then emerge rxvt."
+ einfo "Especially, if you use rxvt under monochrome X you might need to run"
+ einfo "\t RXVT_TERM=rxvt-basic emerge rxvt"
+ einfo "otherwise curses based program will not work."
+ einfo
+}