summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-11-24 10:47:47 +0000
committerPacho Ramos <pacho@gentoo.org>2012-11-24 10:47:47 +0000
commitc5e719646110a051b3a4c64bbc0cfbe40db65e3c (patch)
treef742ccc13ac567b9e3ba78b8c160fd1c685b0e82 /x11-terms
parentBump regex-pcre-builtin to 0.94.4.3.8.31 (diff)
downloadgentoo-2-c5e719646110a051b3a4c64bbc0cfbe40db65e3c.tar.gz
gentoo-2-c5e719646110a051b3a4c64bbc0cfbe40db65e3c.tar.bz2
gentoo-2-c5e719646110a051b3a4c64bbc0cfbe40db65e3c.zip
Stop defaulting to enable login shell as it causes problems (#442062 by Juergen Rose), with this we revert to upstream (and most distributions) default setting.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/ChangeLog11
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.32.1-r1.ebuild42
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.4.1.1-r1.ebuild (renamed from x11-terms/gnome-terminal/gnome-terminal-3.4.0.1.ebuild)15
3 files changed, 60 insertions, 8 deletions
diff --git a/x11-terms/gnome-terminal/ChangeLog b/x11-terms/gnome-terminal/ChangeLog
index ddd943022bad..7a9b8c8b4fd8 100644
--- a/x11-terms/gnome-terminal/ChangeLog
+++ b/x11-terms/gnome-terminal/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-terms/gnome-terminal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.247 2012/10/20 04:48:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.248 2012/11/24 10:47:47 pacho Exp $
+
+*gnome-terminal-2.32.1-r1 (24 Nov 2012)
+*gnome-terminal-3.4.1.1-r1 (24 Nov 2012)
+
+ 24 Nov 2012; Pacho Ramos <pacho@gentoo.org> +gnome-terminal-2.32.1-r1.ebuild,
+ +gnome-terminal-3.4.1.1-r1.ebuild, -gnome-terminal-3.4.0.1.ebuild:
+ Stop defaulting to enable login shell as it causes problems (#442062 by
+ Juergen Rose), with this we revert to upstream (and most distributions)
+ default setting.
20 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
gnome-terminal-2.32.1.ebuild:
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.32.1-r1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.32.1-r1.ebuild
new file mode 100644
index 000000000000..1491d2bdc20f
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.32.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.32.1-r1.ebuild,v 1.1 2012/11/24 10:47:47 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+# libgnome needed for some monospace font schema, bug #274638
+RDEPEND=">=dev-libs/glib-2.25.12:2
+ >=x11-libs/gtk+-2.18:2
+ >=gnome-base/gconf-2.31.3
+ >=x11-libs/vte-0.26.0:0
+ x11-libs/libSM
+ gnome-base/libgnome"
+DEPEND="${RDEPEND}
+ || ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} < 2.32.1-r1 ]]; then
+ elog "Gnome Terminal no longer uses login shell by default, switching"
+ elog "to upstream default. Because of this, if you have some command you"
+ elog "want to be run, be sure to have it placed in your ~/.bashrc file."
+ fi
+}
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.4.0.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.4.1.1-r1.ebuild
index 2192f08bcd86..d4b839dadc40 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-3.4.0.1.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.4.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-3.4.0.1.ebuild,v 1.3 2012/05/03 07:11:33 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-3.4.1.1-r1.ebuild,v 1.1 2012/11/24 10:47:47 pacho Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
IUSE=""
# FIXME: automagic dependency on gtk+[X]
@@ -39,9 +39,10 @@ pkg_setup() {
G2CONF="${G2CONF} --with-gtk=3.0"
}
-src_prepare() {
- # Use login shell by default (#12900)
- epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
-
- gnome2_src_prepare
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} < 3.4.1.1-r1 && ${REPLACING_VERSIONS} != 2.32.1-r1 ]]; then
+ elog "Gnome Terminal no longer uses login shell by default, switching"
+ elog "to upstream default. Because of this, if you have some command you"
+ elog "want to be run, be sure to have it placed in your ~/.bashrc file."
+ fi
}