summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-06-26 09:13:01 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-06-26 09:13:01 +0000
commitc853aa7b913525405933716ee39dc55988ec0f0d (patch)
tree9620ebcf099e8c3093f7beb1d51331cc285c8218 /x11-terms
parentdev-libs/libxml2: download the correct testsuite tarball, see bug #229421 (diff)
downloadgentoo-2-c853aa7b913525405933716ee39dc55988ec0f0d.tar.gz
gentoo-2-c853aa7b913525405933716ee39dc55988ec0f0d.tar.bz2
gentoo-2-c853aa7b913525405933716ee39dc55988ec0f0d.zip
Add patch from upstream to fix behaviour when mrxvt window is completely obscured, bug #229469.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-tuxonice-r5 x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mrxvt/ChangeLog10
-rw-r--r--x11-terms/mrxvt/files/mrxvt-0.5.3-stop-polling-when-obscured.patch13
-rw-r--r--x11-terms/mrxvt/mrxvt-0.5.3-r3.ebuild123
3 files changed, 145 insertions, 1 deletions
diff --git a/x11-terms/mrxvt/ChangeLog b/x11-terms/mrxvt/ChangeLog
index c542bdcffdd8..e0742bd05937 100644
--- a/x11-terms/mrxvt/ChangeLog
+++ b/x11-terms/mrxvt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-terms/mrxvt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.66 2008/06/10 22:05:42 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.67 2008/06/26 09:13:01 nelchael Exp $
+
+*mrxvt-0.5.3-r3 (26 Jun 2008)
+
+ 26 Jun 2008; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/mrxvt-0.5.3-stop-polling-when-obscured.patch,
+ +mrxvt-0.5.3-r3.ebuild:
+ Add patch from upstream to fix behaviour when mrxvt window is completely
+ obscured, bug #229469.
10 Jun 2008; Krzysiek Pawlik <nelchael@gentoo.org>
-files/mrxvt-0.5.2-no_debug_x.patch, -mrxvt-0.5.1.ebuild,
diff --git a/x11-terms/mrxvt/files/mrxvt-0.5.3-stop-polling-when-obscured.patch b/x11-terms/mrxvt/files/mrxvt-0.5.3-stop-polling-when-obscured.patch
new file mode 100644
index 000000000000..191f07f5b9c9
--- /dev/null
+++ b/x11-terms/mrxvt/files/mrxvt-0.5.3-stop-polling-when-obscured.patch
@@ -0,0 +1,13 @@
+Index: src/command.c
+===================================================================
+--- src/command.c (revision 292)
++++ src/command.c (revision 293)
+@@ -1966,7 +1966,7 @@
+ value->tv_sec = 0;
+
+
+- if (!r->TermWin.mapped)
++ if( !r->TermWin.mapped || r->h->refresh_type == NO_REFRESH )
+ quick_timeout = 0;
+ else
+ {
diff --git a/x11-terms/mrxvt/mrxvt-0.5.3-r3.ebuild b/x11-terms/mrxvt/mrxvt-0.5.3-r3.ebuild
new file mode 100644
index 000000000000..54d16f6cd549
--- /dev/null
+++ b/x11-terms/mrxvt/mrxvt-0.5.3-r3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/mrxvt-0.5.3-r3.ebuild,v 1.1 2008/06/26 09:13:01 nelchael Exp $
+
+inherit eutils
+
+DESCRIPTION="Multi-tabbed rxvt clone with XFT, transparent background and CJK support"
+HOMEPAGE="http://materm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/materm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~x86"
+
+LINGUAS_IUSE="linguas_el linguas_ja linguas_ko linguas_th linguas_zh_CN linguas_zh_TW"
+IUSE="debug png jpeg session truetype menubar utempter xpm ${LINGUAS_IUSE}"
+
+RDEPEND="png? ( media-libs/libpng )
+ utempter? ( sys-libs/libutempter )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( virtual/xft
+ media-libs/fontconfig
+ media-libs/freetype )
+ x11-libs/libX11
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )
+ x11-libs/libXrender"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-no-scroll-with-buffer.patch"
+ epatch "${FILESDIR}/${P}-display-security.patch"
+ epatch "${FILESDIR}/${P}-stop-polling-when-obscured.patch"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ # if you want to pass any other flags, use EXTRA_ECONF.
+ if use linguas_el ; then
+ myconf="${myconf} --enable-greek"
+ fi
+ if use linguas_ja ; then
+ # --with-encoding=sjis
+ myconf="${myconf} --enable-kanji --with-encoding=eucj"
+ fi
+ if use linguas_ko ; then
+ myconf="${myconf} --enable-kr --with-encoding=kr"
+ fi
+ if use linguas_th ; then
+ myconf="${myconf} --enable-thai"
+ fi
+ if use linguas_zh_CN ; then
+ # --with-encoding=gbk
+ myconf="${myconf} --enable-gb --with-encoding=gb"
+ fi
+ if use linguas_zh_TW ; then
+ myconf="${myconf} --enable-big5 --with-encoding=big5"
+ fi
+
+ # 2006-03-13 gi1242: mrxvt works best with TERM=rxvt AND correctly set
+ # termcap / terminfo entries. If the rxvt termcap / terminfo entries are
+ # messed up then then it's better to set TERM=xterm.
+ #
+ # Provide support for this by setting the or RXVT_TERM environment variables
+ # before emerging, as done in the rxvt ebuild.
+
+ if [[ -n ${RXVT_TERM} ]]; then
+ myconf="${myconf} --with-term=${RXVT_TERM}"
+ fi
+
+ econf \
+ --enable-everything \
+ --with-atab-extra=25 \
+ $(use_enable debug) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable xpm) \
+ $(use_enable session sessionmgr) \
+ $(use_enable truetype xft) \
+ $(use_enable utempter) \
+ $(use_enable menubar) \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
+ # Give mrxvt perms to update utmp
+ fowners root:utmp /usr/bin/mrxvt
+ fperms g+s /usr/bin/mrxvt
+ dodoc AUTHORS CREDITS ChangeLog FAQ NEWS README* TODO
+
+}
+
+pkg_postinst() {
+
+ if [[ -z $RXVT_TERM ]]; then
+ einfo
+ einfo "If you experience problems with curses programs, then this is"
+ einfo "most likely because of incorrectly set termcap / terminfo"
+ einfo "entries. To fix this you can dry and run (as user)"
+ einfo " tic /usr/share/doc/${P}/etc/mrxvt.terminfo"
+ einfo "Alternately, run the offending programs with TERM=xterm."
+ einfo
+ einfo "To emerge mrxvt with TERM=xterm by default, set the RXVT_TERM"
+ einfo "environment variable to 'xterm', or your desired default"
+ einfo "terminal name. Alternately you can put 'Mrxvt.termName: xterm'"
+ einfo "in your ~/.mrxvtrc, or /etc/mrxvt/mrxvtrc."
+ einfo
+ fi
+
+}