summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-11-04 04:51:58 +0000
committerBen de Groot <yngwin@gentoo.org>2013-11-04 04:51:58 +0000
commit21dd08d5dac918249aa16c15d5fcaf8e6c121ce2 (patch)
treeca1c24bd54d797c16382abdb214020495572f9d7 /x11-themes/qtcurve
parentalpha stable, bug 488946. (diff)
downloadgentoo-2-21dd08d5dac918249aa16c15d5fcaf8e6c121ce2.tar.gz
gentoo-2-21dd08d5dac918249aa16c15d5fcaf8e6c121ce2.tar.bz2
gentoo-2-21dd08d5dac918249aa16c15d5fcaf8e6c121ce2.zip
Move stable qtcurve-qt4 here to complete the move
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x2B2474AD43CE296E!)
Diffstat (limited to 'x11-themes/qtcurve')
-rw-r--r--x11-themes/qtcurve/ChangeLog8
-rw-r--r--x11-themes/qtcurve/files/qtcurve_kwin_automagic_fix.patch38
-rw-r--r--x11-themes/qtcurve/qtcurve-1.8.14.ebuild52
3 files changed, 97 insertions, 1 deletions
diff --git a/x11-themes/qtcurve/ChangeLog b/x11-themes/qtcurve/ChangeLog
index de12fd64589f..febd8108a2cd 100644
--- a/x11-themes/qtcurve/ChangeLog
+++ b/x11-themes/qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/qtcurve
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/ChangeLog,v 1.76 2013/11/03 08:17:51 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/ChangeLog,v 1.77 2013/11/04 04:51:58 yngwin Exp $
+
+*qtcurve-1.8.14 (04 Nov 2013)
+
+ 04 Nov 2013; Ben de Groot <yngwin@gentoo.org>
+ +files/qtcurve_kwin_automagic_fix.patch, +qtcurve-1.8.14.ebuild:
+ Move stable qtcurve-qt4 here to complete the move
*qtcurve-1.8.17 (03 Nov 2013)
diff --git a/x11-themes/qtcurve/files/qtcurve_kwin_automagic_fix.patch b/x11-themes/qtcurve/files/qtcurve_kwin_automagic_fix.patch
new file mode 100644
index 000000000000..ab20c5bdfa9d
--- /dev/null
+++ b/x11-themes/qtcurve/files/qtcurve_kwin_automagic_fix.patch
@@ -0,0 +1,38 @@
+diff -u -r QtCurve-KDE4-1.6.4-old/CMakeLists.txt QtCurve-KDE4-1.6.4/CMakeLists.txt
+--- QtCurve-KDE4-1.6.4-old/CMakeLists.txt 2010-10-19 12:24:18.725632000 +0300
++++ QtCurve-KDE4-1.6.4/CMakeLists.txt 2010-10-19 12:26:30.469632000 +0300
+@@ -88,14 +88,16 @@
+ add_subdirectory(colors)
+ add_subdirectory(po)
+
+- find_file(KWINGLOBALS_H kwinglobals.h ${KDE4_INCLUDES}) # kwinglobals.h is new for KDE4
++ if (QTC_KWIN)
++ find_file(KWINGLOBALS_H kwinglobals.h ${KDE4_INCLUDES}) # kwinglobals.h is new for KDE4
+
+- if (KWINGLOBALS_H)
+- add_subdirectory(kwin)
+- add_subdirectory(kwinconfig)
+- else (KWINGLOBALS_H)
+- message("** KWin headers not found - KWin decoration will not be built")
+- endif (KWINGLOBALS_H)
++ if (KWINGLOBALS_H)
++ add_subdirectory(kwin)
++ add_subdirectory(kwinconfig)
++ else (KWINGLOBALS_H)
++ message("** KWin headers not found - KWin decoration will not be built")
++ endif (KWINGLOBALS_H)
++ endif (QTC_KWIN)
+ else (NOT QTC_QT_ONLY)
+ set(CMAKE_INSTALL_PREFIX ${OLD_CMAKE_INSTALL_PREFIX})
+ add_definitions(${QT_DEFINITIONS})
+diff -u -r QtCurve-KDE4-1.6.4-old/config.h.cmake QtCurve-KDE4-1.6.4/config.h.cmake
+--- QtCurve-KDE4-1.6.4-old/config.h.cmake 2010-10-19 12:24:18.725632000 +0300
++++ QtCurve-KDE4-1.6.4/config.h.cmake 2010-10-19 12:24:42.264632000 +0300
+@@ -6,6 +6,7 @@
+ #define KDE4PREFIX "@KDE4PREFIX@"
+
+ #cmakedefine QTC_QT_ONLY
++#cmakedefine QTC_KWIN
+ #cmakedefine QTC_OLD_NVIDIA_ARROW_FIX
+ #cmakedefine QTC_STYLE_SUPPORT
+ #cmakedefine QTC_KWIN_MAX_BUTTON_HACK
diff --git a/x11-themes/qtcurve/qtcurve-1.8.14.ebuild b/x11-themes/qtcurve/qtcurve-1.8.14.ebuild
new file mode 100644
index 000000000000..62c7daf51a26
--- /dev/null
+++ b/x11-themes/qtcurve/qtcurve-1.8.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/qtcurve-1.8.14.ebuild,v 1.1 2013/11/04 04:51:58 yngwin Exp $
+
+EAPI=4
+KDE_REQUIRED="optional"
+inherit cmake-utils kde4-base
+
+MY_P="${P/qtcurve/QtCurve-KDE4}"
+
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86"
+IUSE="kde windeco"
+REQUIRED_USE="windeco? ( kde )"
+
+DEPEND="dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ kde? (
+ $(add_kdebase_dep systemsettings)
+ windeco? ( $(add_kdebase_dep kwin) )
+ )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog README TODO )
+PATCHES=( "${FILESDIR}/${PN}_kwin_automagic_fix.patch" )
+
+pkg_setup() {
+ use kde && kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs
+ if use kde; then
+ mycmakeargs=(
+ $(cmake-utils_use windeco QTC_KWIN)
+ )
+ kde4-base_src_configure
+ else
+ mycmakeargs=(
+ "-DQTC_QT_ONLY=true"
+ )
+ cmake-utils_src_configure
+ fi
+}