summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-20 20:26:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-20 20:26:17 +0000
commite7d89f262e318acbc27b9b9aca1d843d26c4db30 (patch)
tree3322835b7dbb370ccd0a822d7d57b26a1530506e /x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
parentminor doc fix (diff)
downloadgentoo-2-e7d89f262e318acbc27b9b9aca1d843d26c4db30.tar.gz
gentoo-2-e7d89f262e318acbc27b9b9aca1d843d26c4db30.tar.bz2
gentoo-2-e7d89f262e318acbc27b9b9aca1d843d26c4db30.zip
initial
Diffstat (limited to 'x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild')
-rw-r--r--x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild b/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
new file mode 100644
index 000000000000..b997ad92b292
--- /dev/null
+++ b/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild,v 1.1 2002/11/20 20:26:17 mkennedy Exp $
+
+IUSE=""
+
+DESCRIPTION="Goodies for aewm++."
+HOMEPAGE="http://sapphire.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sapphire/${P/-/_}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/x11"
+
+S="${WORKDIR}/${PN/-/_}"
+
+GOODIES="ae_fspanel-1.0 appbar-1.0 setrootimage-1.0"
+
+src_unpack() {
+ unpack ${A}
+ # compatibility with ANSI C++ and GCC3.2
+ cd ${S} && patch -p1 <${FILESDIR}/aewm++-goodies-gcc3-gentoo.patch || die
+}
+
+src_compile() {
+ for i in ${GOODIES}
+ do
+ make CFLAGS="${CFLAGS}" -C $i || die
+ done
+}
+
+src_install() {
+ dodir /usr/bin
+ for i in ${GOODIES}
+ do
+ make DESTDIR=${D} -C $i install || die
+ docinto $i
+ dodoc $i/{README,ChangeLog,COPYING,LICENSE}
+ done
+}