summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2015-05-06 12:45:37 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2015-05-06 12:45:37 +0000
commit265cff0829a10ddb332f6b57e203ee29b27861eb (patch)
treedcdb1ca262a9d46e3dfc7805e2004be2ffe74dad /x11-wm/fluxbox
parentRemove old. (diff)
downloadgentoo-2-265cff0829a10ddb332f6b57e203ee29b27861eb.tar.gz
gentoo-2-265cff0829a10ddb332f6b57e203ee29b27861eb.tar.bz2
gentoo-2-265cff0829a10ddb332f6b57e203ee29b27861eb.zip
Fix bug 509014.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/ChangeLog5
-rw-r--r--x11-wm/fluxbox/fluxbox-9999.ebuild13
2 files changed, 11 insertions, 7 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 8b3e220c4ecc..847ce06aed48 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.335 2015/05/06 11:05:47 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.336 2015/05/06 12:45:37 titanofold Exp $
+
+ 06 May 2015; Aaron W. Swenson <titanofold@gentoo.org> fluxbox-9999.ebuild:
+ Fix bug 509014.
*fluxbox-1.3.7-r1 (06 May 2015)
diff --git a/x11-wm/fluxbox/fluxbox-9999.ebuild b/x11-wm/fluxbox/fluxbox-9999.ebuild
index 50dd49a48e02..4f73f774ff1b 100644
--- a/x11-wm/fluxbox/fluxbox-9999.ebuild
+++ b/x11-wm/fluxbox/fluxbox-9999.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v 1.14 2015/01/26 12:31:03 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v 1.15 2015/05/06 12:45:37 titanofold Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs git-2 prefix
-IUSE="nls xinerama bidi +truetype +imlib +slit +toolbar vim-syntax"
+IUSE="nls xinerama bidi +truetype +imlib +slit +systray +toolbar vim-syntax"
+
+REQUIRED_USE="systray? ( toolbar )"
DESCRIPTION="Fluxbox is an X11 window manager featuring tabs and an iconbar"
@@ -64,13 +66,12 @@ src_prepare() {
src_configure() {
use bidi && append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)"
- econf ${myconf} \
- $(use_enable bidi fribidi ) \
+ econf $(use_enable bidi fribidi ) \
$(use_enable imlib imlib2) \
$(use_enable nls) \
$(use_enable slit ) \
+ $(use_enable systray) \
$(use_enable toolbar ) \
- $(use_enable toolbar systray ) \
$(use_enable truetype xft) \
$(use_enable xinerama) \
--sysconfdir="${EPREFIX}"/etc/X11/${PN} \
@@ -78,7 +79,7 @@ src_configure() {
}
src_compile() {
- emake
+ default
ebegin "Creating a menu file (may take a while)"
mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"