summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-07-13 18:37:55 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-07-13 18:37:55 +0000
commit11f499d456a1dc6fc4028cee863044826b38cbd3 (patch)
tree6be6e80aea9b586760f29b2ce2b9357aa8c3ad0b /x11-wm/flwm
parentCryptographic library for embedded systems (diff)
downloadgentoo-2-11f499d456a1dc6fc4028cee863044826b38cbd3.tar.gz
gentoo-2-11f499d456a1dc6fc4028cee863044826b38cbd3.tar.bz2
gentoo-2-11f499d456a1dc6fc4028cee863044826b38cbd3.zip
Die when fltk is compiled with xft support, thanks to John <greydruid at gmail.com>, wrt bug #99993. Use toolchain-funcs and general clean up.
(Portage version: 2.1.2.9)
Diffstat (limited to 'x11-wm/flwm')
-rw-r--r--x11-wm/flwm/ChangeLog7
-rw-r--r--x11-wm/flwm/files/flwm-1.00-fltk1.1.patch (renamed from x11-wm/flwm/files/fltk1.1.patch)0
-rw-r--r--x11-wm/flwm/flwm-1.00-r4.ebuild66
3 files changed, 43 insertions, 30 deletions
diff --git a/x11-wm/flwm/ChangeLog b/x11-wm/flwm/ChangeLog
index 056fbd107bdf..9a578fcf16cc 100644
--- a/x11-wm/flwm/ChangeLog
+++ b/x11-wm/flwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/flwm
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/ChangeLog,v 1.12 2007/02/21 22:36:14 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/ChangeLog,v 1.13 2007/07/13 18:37:55 coldwind Exp $
+
+ 13 Jul 2007; Santiago M. Mola <coldwind@gentoo.org>
+ +files/flwm-1.00-fltk1.1.patch, -files/fltk1.1.patch, flwm-1.00-r4.ebuild:
+ Die when fltk is compiled with xft support, thanks to John <greydruid at
+ gmail.com>, wrt bug #99993. Use flag-o-matic and general clean up.
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-wm/flwm/files/fltk1.1.patch b/x11-wm/flwm/files/flwm-1.00-fltk1.1.patch
index 12483682af7e..12483682af7e 100644
--- a/x11-wm/flwm/files/fltk1.1.patch
+++ b/x11-wm/flwm/files/flwm-1.00-fltk1.1.patch
diff --git a/x11-wm/flwm/flwm-1.00-r4.ebuild b/x11-wm/flwm/flwm-1.00-r4.ebuild
index f3a12f529aac..2350bb544337 100644
--- a/x11-wm/flwm/flwm-1.00-r4.ebuild
+++ b/x11-wm/flwm/flwm-1.00-r4.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r4.ebuild,v 1.11 2007/07/12 03:41:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r4.ebuild,v 1.12 2007/07/13 18:37:55 coldwind Exp $
-inherit eutils
-
-IUSE="opengl"
+inherit eutils flag-o-matic
DESCRIPTION="A lightweight window manager based on fltk"
-SRC_URI="http://flwm.sourceforge.net/${P}.tgz"
HOMEPAGE="http://flwm.sourceforge.net"
+SRC_URI="http://flwm.sourceforge.net/${P}.tgz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc amd64"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="opengl"
DEPEND="=x11-libs/fltk-1.1*
opengl? ( virtual/opengl )"
+RDEPEND="${DEPEND}"
#Configuration of the appearance and behavior of flwm
#must be done at compile time, i.e. there is
@@ -27,35 +27,43 @@ DEPEND="=x11-libs/fltk-1.1*
#in pkg_postinst to tell the user to 'ebuild unpack'
#and edit the config.h to their liking.
-src_compile() {
-
- use opengl && export X_EXTRA_LIBS=-lGL
+pkg_setup() {
+ if ! built_with_use x11-libs/fltk noxft ; then
+ eerror "${PN} requires x11-libs/fltk built without xft support."
+ eerror "Please, reinstall x11-libs/fltk with USE=\"noxft\""
+ eerror "before installing ${PN}."
+ die "fltk without noxft"
+ fi
+}
- export CXXFLAGS="${CXXFLAGS} -I/usr/include/fltk-1.1"
- export LIBS="-L/usr/lib/fltk-1.1"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fltk1.1.patch"
+}
- epatch ${FILESDIR}/fltk1.1.patch
+src_compile() {
+ use opengl && export X_EXTRA_LIBS=-lGL
+ append-flags -I/usr/include/fltk-1.1
+ append-ldflags -L/usr/lib/fltk-1.1
- econf || die
- make || die
+ econf || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
-
- doman flwm.1
- dodoc README flwm_wmconfig
-
- into /usr
- dobin flwm
+ doman flwm.1 || die
+ dodoc README flwm_wmconfig || die
+ dobin flwm || die
}
pkg_postinst() {
- einfo "Customization of behaviour and appearance of"
- einfo "flwm requires manually editing the config.h"
- einfo "source file. If you want to change the defaults,"
- einfo "do the following:"
- einfo ""
- einfo "\tebuild ${P}.ebuild unpack"
- einfo "\t${EDITOR} ${S}/config.h "
- einfo "\tebuild ${P} compile install qmerge"
+ elog "Customization of behaviour and appearance of"
+ elog "flwm requires manually editing the config.h"
+ elog "source file. If you want to change the defaults,"
+ elog "do the following:"
+ elog ""
+ elog "\tebuild ${P}.ebuild unpack"
+ elog "\t${EDITOR} ${S}/config.h "
+ elog "\tebuild ${P} compile install qmerge"
}