summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-08 00:58:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-08 00:58:44 +0000
commit1c3514a94fd487b42ce768693d24cc95802b3997 (patch)
tree480a8fa9424c3717462a6d4ae938c0395e09adf7 /x11-wm/icewm
parentUpdate (diff)
downloadgentoo-2-1c3514a94fd487b42ce768693d24cc95802b3997.tar.gz
gentoo-2-1c3514a94fd487b42ce768693d24cc95802b3997.tar.bz2
gentoo-2-1c3514a94fd487b42ce768693d24cc95802b3997.zip
Update
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.0.8.61
-rw-r--r--x11-wm/icewm/icewm-1.0.8.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-wm/icewm/files/digest-icewm-1.0.8.6 b/x11-wm/icewm/files/digest-icewm-1.0.8.6
new file mode 100644
index 000000000000..b24c5af82d16
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.0.8.6
@@ -0,0 +1 @@
+MD5 a37b0d4d350c42d01c602bbc66b29380 icewm-1.0.8-6.tar.gz
diff --git a/x11-wm/icewm/icewm-1.0.8.6.ebuild b/x11-wm/icewm/icewm-1.0.8.6.ebuild
new file mode 100644
index 000000000000..e503df2849ec
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.0.8.6.ebuild
@@ -0,0 +1,27 @@
+#Author Nathaniel Hirsch <nh2@njit.edu>
+
+A=icewm-1.0.8-6.tar.gz
+S=${WORKDIR}/icewm-1.0.8
+DESCRIPTION="Ice Window Manager"
+SRC_URI="prdownloads.sourceforge.net/icewm/${A}"
+HOMEPAGE="www.icewm.org"
+
+DEPEND="virtual/x11"
+
+src_compile(){
+ try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/X11/
+ try make
+}
+src_install(){
+
+ try make prefix=${D}/usr/X11R6 DOCDIR=${S}/dummy install
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/icewm
+ dodoc BUGS CHANGES COPYING FAQ PLATFORMS README TODO VERSION
+ docinto html
+ dodoc doc/*.html
+ docinto sgml
+ dodoc doc/*.sgml
+
+}
+