summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-16 11:41:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-16 11:41:32 +0000
commit6ea63f24fac6ae661794464982515d7bbada1798 (patch)
treeae925221ef62aa7ec9ee8bf745281b0bec2c7d56 /x11-wm/icewm
parentadded new ebuild, htag (diff)
downloadgentoo-2-6ea63f24fac6ae661794464982515d7bbada1798.tar.gz
gentoo-2-6ea63f24fac6ae661794464982515d7bbada1798.tar.bz2
gentoo-2-6ea63f24fac6ae661794464982515d7bbada1798.zip
help works again
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog10
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.0-r11
-rw-r--r--x11-wm/icewm/icewm-1.2.0-r1.ebuild95
3 files changed, 105 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 1fcd241455f8..2ea179b28b28 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.8 2002/07/07 01:41:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.9 2002/08/16 11:41:32 seemant Exp $
+
+*icewm-1.2.0-r1 (16 Aug 2002)
+
+ 16 Aug 2002; Seemant Kulleen <seemant@gentoo.org> icewm-1.2.0-r1.ebuild
+ files/digest-icewm-1.2.0-r1 :
+
+ Now, the help browser knows where the help files are. Closes bug #6405 by
+ Klaus.Kusche@inode.at (Klaus Kusche)
*icewm-1.2.0 (06 Jul 2002)
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.0-r1 b/x11-wm/icewm/files/digest-icewm-1.2.0-r1
new file mode 100644
index 000000000000..fbfead7c707d
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.0-r1
@@ -0,0 +1 @@
+MD5 0972000f4f0569c34ff03c8db200d396 icewm-1.2.0.tar.gz 684306
diff --git a/x11-wm/icewm/icewm-1.2.0-r1.ebuild b/x11-wm/icewm/icewm-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..47dad4786a58
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.0-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.0-r1.ebuild,v 1.1 2002/08/16 11:41:32 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ice Window Manager"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="www.icewm.org"
+
+DEPEND="virtual/x11
+ esd? ( media-sound/esound )
+ nls? ( sys-devel/gettext )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ truetype? ( >=media-libs/freetype-2.0.9 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_unpack(){
+ unpack ${A}
+
+ cd ${S}
+
+ patch -p1< ${FILESDIR}/${P}-gcc31-gentoo.patch || die
+
+ # icewm's doc dir layout is un-gentoo-like. To fix it, we have
+ # "make install" skip the docs install, and do it ourselves. That also
+ # means we have to adjust the Makefile so that it can find the help files
+ # when you choose the 'help' item out of its menu.
+ cp Makefile.in Makefile.in.orig
+ sed 's:icewm-$(VERSION)::' \
+ Makefile.in.orig > Makefile.in
+
+ cp Makefile Makefile.orig
+ sed 's:icewm-$(VERSION)::' \
+ Makefile.orig > Makefile
+
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed 's:icewm-$(VERSION)::' \
+ Makefile.orig > Makefile
+}
+
+src_compile(){
+
+ use esd \
+ && myconf="${myconf} --with-esd-config=/usr/bin/esd-config"
+
+ use nls \
+ && myconf="${myconf} --enable-nls --enable-i18n" \
+ || myconf="${myconf} --disable-nls --disable-i18n"
+
+ use imlib \
+ && myconf="${myconf} --with-imlib" \
+ || myconf="${myconf} --without-imlib"
+
+ use truetype \
+ && myconf="${myconf} --enable-gradients" \
+ || myconf="${myconf} --disable-xfreetype"
+
+ # until the new sexy use style arch code is implemented...
+ if [ ${ARCH} != "x86" ]
+ then
+ myconf="${myconf} --disable-x86-asm"
+ else
+ myconf="${myconf} --enable-x86-asm"
+ fi
+
+ econf \
+ --with-libdir=/usr/lib/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ make \
+ prefix=${D}/usr \
+ LIBDIR=${D}/usr/lib/icewm \
+ CFGDIR=${D}/etc/icewm \
+ LOCDIR=${D}/usr/share/locale \
+ DOCDIR=${S}/share/doc/${PF} \
+ install || die "make install failed"
+
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ echo "#!/bin/bash" > icewm
+ echo "/usr/bin/icewm" >> icewm
+ exeinto /etc/X11/Sessions
+ doexe icewm
+}