summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-10-20 20:25:11 +0000
committerDamon Conway <kabau@gentoo.org>2001-10-20 20:25:11 +0000
commit32f37a82ad6c2644c66784f8dc762ee2926f8256 (patch)
tree399f49d0cfe620d22b4fa8ba8c11bb4967045115 /x11-wm/ion
parentadded optional ipv6 functionality (diff)
downloadgentoo-2-32f37a82ad6c2644c66784f8dc762ee2926f8256.tar.gz
gentoo-2-32f37a82ad6c2644c66784f8dc762ee2926f8256.tar.bz2
gentoo-2-32f37a82ad6c2644c66784f8dc762ee2926f8256.zip
Initial commit of ion. It is a keyboard controlled window manager.
Diffstat (limited to 'x11-wm/ion')
-rw-r--r--x11-wm/ion/files/digest-ion-200105231
-rw-r--r--x11-wm/ion/ion-20010523.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-wm/ion/files/digest-ion-20010523 b/x11-wm/ion/files/digest-ion-20010523
new file mode 100644
index 000000000000..7e9ba3c6956f
--- /dev/null
+++ b/x11-wm/ion/files/digest-ion-20010523
@@ -0,0 +1 @@
+MD5 63e8e076c57085a633ffdc5c08447ba0 ion-20010523.tar.gz 151552
diff --git a/x11-wm/ion/ion-20010523.ebuild b/x11-wm/ion/ion-20010523.ebuild
new file mode 100644
index 000000000000..5ee1109b47a8
--- /dev/null
+++ b/x11-wm/ion/ion-20010523.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Damon Conway <kabau@gentoo.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.8 2001/10/11 17:50:47 woodchip Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A keyboard-based window manager"
+SRC_URI="http://www.students.tut.fi/~tuomov/dl/ion-20010523.tar.gz"
+HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
+DEPEND="virtual/glibc"
+RDEPEND="virtual/x11"
+
+src_compile() {
+ cd ${S}
+
+ # Edit system.mk
+ sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \
+ -e 's:ETCDIR=$(PREFIX):ETCDIR=:' \
+ -e 's:$(PREFIX)/man:$(PREFIX)/share/man:' \
+ -e 's:$(PREFIX)/doc:$(PREFIX)/share/doc:' \
+ -e 's:#HAS_SYSTEM_ASPRINTF=1:HAS_SYSTEM_ASPRINTF=1:' \
+ -e 's:#INSTALL=install -c:INSTALL=install -c:' \
+ -e 's:INSTALL=install *$:#INSTALL=install:' \
+ system.mk > system.mk.new
+ mv system.mk.new system.mk
+
+ # Edit Makefile
+ # I don't know how to use ${P} instead of typing the whole version
+ # here. At some point, it should be cleaned up.
+ sed -e 's:$(DOCDIR)/ion:$(DOCDIR)/ion-20010523:g' Makefile > Makefile.new
+ mv Makefile.new Makefile
+
+ make depend || die
+ emake || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr ETCDIR=${D}/etc install || die
+}
+
+pkg_postinst () {
+ einfo "Configuration documentation can be found in these places:"
+ einfo "/usr/share/doc/${P}/config.txt"
+ einfo "http://www.students.tut.fi/~tuomov/ion/resources.html"
+}