summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-06-20 18:59:46 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-06-20 18:59:46 +0000
commitf664149f5cba0f87bbfb0eed87dc8a770bb33c35 (patch)
treeed7b22a8859a9b01865c5eadf1c99bd0806e8fdc /x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild
parentLittle fix to the LINGUAS stuff (diff)
downloadgentoo-2-f664149f5cba0f87bbfb0eed87dc8a770bb33c35.tar.gz
gentoo-2-f664149f5cba0f87bbfb0eed87dc8a770bb33c35.tar.bz2
gentoo-2-f664149f5cba0f87bbfb0eed87dc8a770bb33c35.zip
Fixed gcc4 compile issues and removed nested c functions, fixes bug #137026.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild')
-rw-r--r--x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild b/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild
index 08e9e4b3efd3..05713c05363f 100644
--- a/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild
+++ b/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 2006-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild,v 1.1 2006/06/04 21:42:08 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild,v 1.2 2006/06/20 18:59:46 yvasilev Exp $
-inherit versionator
+inherit eutils versionator
DESCRIPTION="The Matchbox Panel"
HOMEPAGE="http://projects.o-hand.com/matchbox/"
@@ -20,6 +20,13 @@ DEPEND=">=x11-libs/libmatchbox-1.5
RDEPEND="${DEPEND}
x11-wm/matchbox-common"
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-gcc4-no-nested-functions.patch"
+}
+
src_compile() {
econf $(use_enable debug) \
$(use_enable nls) \